System requirements for Presentation Server


Hardware requirements

After you determine the size of your environment, consult the following table for recommended hardware.

Notes

  • The recommended hardware requirements apply to both physical or virtual machines.
  • Parallel CPUs usually improve user response time better than a single CPU with a higher clock speed.
  • (Applicable to POC and medium environments only) The installer validates the system to check if the following system requirements are met. If your target computer does not meet these requirements, you cannot proceed with the installation (or upgrade). However, in a non-production environment, you can skip the system requirements validation with the -J MINIMAL=true parameter.

      Requirements for installation and upgrade
    • Total RAM (in MB): 32,000
    • Available RAM (in MB): 25,000
    • Total swap space / page file (in MB): 8,000
    • Available swap space / page file (in MB): 8,000

    For more information, see the installing or upgrading instructions
    .

Environment Sizing requirements Platform and size
POC or Demo CPU
  • CPU: 4 vCPU
  • Frequency: 2.6 GHz and above
RAM 8 GB
Storage configuration 100 GB
Medium CPU
  • CPU: 4 vCPU
  • Frequency: 2.6 GHz and above
RAM1

32 GB*

*Based on the latest performance testing, it is now recommended to use 32 GB RAM instead of the previously recommended 24 GB.

Storage configuration

200 GB

Large



CPU

  • CPU: 8/16 vCPU*
  • Frequency: 2.6 GHz and above
*(For 11.3.02 and later only, not supported on 11.3.01) If the infrastructure policies range from 4,000 to 20,000 and/or concurrent users range from 50 to 150, it is recommended to use 16 vCPUs.

RAM1

48 GB*

*Based on the latest performance testing, it is now recommended to use 48 GB RAM instead of the previously recommended 32 GB.

Storage configuration

400 GB

1 - If you plan to use TrueSight Presentation Server with the TrueSight Capacity Optimization component only, the minimum RAM requirement is 8 GB.


Operating system requirements

Microsoft Windows

Component

Requirement

User Rights

Administrative privileges

Supported versions of Microsoft Windows

Microsoft Windows 2019

  • Microsoft Windows 2019 Standard Edition (64-bit)
  • Microsoft Windows 2019 Datacenter Edition (64-bit)

Microsoft Windows 2016

  • Microsoft Windows 2016 Standard Edition (64-bit)
  • Microsoft Windows 2016 Datacenter Edition (64-bit)

Microsoft Windows 2012 

  • Microsoft Windows 2012 R2 Standard Edition (64-bit)  
  • Microsoft Windows 2012 R2 Datacenter Edition (64-bit)
  • Microsoft Windows 2012 Standard Edition (64-bit)  
  • Microsoft Windows 2012 Datacenter Edition (64-bit)  

Microsoft Windows 2008

  • Microsoft Windows 2008 R2 Standard Edition (64-bit)
  • Microsoft Windows 2008 R2 Datacenter Edition (64-bit)
  • Microsoft Windows 2008 R2 Enterprise Edition (64-bit)

Note

Installing the TrueSight Presentation Server on the Windows computer with the Korean locale is not supported as PostgreSQL 9.4.4 is not supported on the same.

Linux

Component

Requirement

User Rights

A non-root user who has modification permissions to specific directories and files.
A user with root privileges cannot install the TrueSight Presentation Server.

Supported versions of Linux

  • Red Hat Enterprise Linux 6.x and 7.x
  • SUSE Linux Enterprise Server 11.x, 12.x, and 15
  • Oracle Linux Server 6.x and 7.x

Notes

  • BMC products are certified for use on supported operating system versions. BMC does not explicitly test for OS patches/updates that are released after a BMC product is released.
  • BMC products should work fine with minor updates to these supported operating systems. For assistance, contact BMC Customer Support.

Red Hat subscription 

The product requires some additional libraries to be present on the system (see list below).

The preferred method to add any missing libraries is to use the yum command to fetch the necessary library packages from the RHN (Red Hat Network) repository via the Internet.  To use this method, a Red Hat subscription is needed. Register the system by clicking System > Administration > Red Hat Subscription Manager in the menu on the server itself.  After registering the system, you can use yum install to download and install the required libraries from the RHN.

X Windows 

If you are installing the TrueSight Presentation Server by using the graphical user interface, you must install X Windows.

On the Red Hat Enterprise Linux terminal, type yum grouplist and check that X Window System is listed.  If not, then run yum groupinstall 'X Window System' to install the necessary packages.   

Required libraries

Ensure that the following libraries are present to install the TrueSight Presentation Server.  To install the libraries, use the following commands.

Library

Command to install the library on RHEL

Command to install the library on SUSE

libXtst (32-bit)

libXtst (64-bit)

yum install libXtst.i686 libXtst.x86_64

    libXtst-1.0.1-3.1

    libX11-devel-1.0.3-11.el5

N/A

glibc (32-bit)

glibc (64-bit)

yum install glibc.i686 glibc.x86_64

    glibc-2.12.x86_64

    glibc-2.12-1.107.el6.i686

    glibc-devel-2.5-65

zypper install glibc-32bit glibc

libstdc++ (32-bit)

libstdc++ (64-bit)

yum install libstdc++.i686 libstdc++.x86_64

zypper install libstdc++-32bit libstdc++

compat-libstdc++-33 (32-bit)

compat-libstdc++-33 (64-bit)

yum install compat-libstdc++-33.i686 

    compat-libstdc++-33.x86_64

    compat-libstdc++-33-3.2.3-69.e16.i686 

zypper install libstdc++33-32bit libstdc++33 

compat-libstdc++-296 (32-bit)

yum install compat-libstdc++-296.i686

N/A

pam (32-bit)

pam (64-bit)

yum install pam.i686 pam.x86_64

    pam-1.1.1-13.e16.i686

zypper install pam-32bit pam

libgtk-x11-2 (32-bit)

yum install libgtk-x11-2.0.so.0

N/A

Authentication requirements

Remedy Single Sign-On is the authentication tool that must be installed and configured with the Presentation Server. The following versions are supported:

TrueSight Presentation Server versions

11.3.01, 11.3.02

Remedy Single Sign-On version

9.1.03 and later


Remedy SSO latest patches and hot fixes

  • If you have Remedy Single Sign-On installed, you must check and apply the relevant patches for a seamless integration with the TrueSight Presentation Server.
  • Before proceeding with the patch installation, if the TrueSight Presentation Server is running, stop the TrueSight Presentation Server and back up Remedy Single Sign-On.

 

Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Giles Day

    There appears to be an error in the Authentication requirements:

    Page not found for multiexcerpt macro. The page: .Remedy Single Sign-On at-a-glance v11.3.01 was not found. Please check/update the page name used in the 'multiexcerpt-include macro.

    Jan 10, 2019 08:52
    1. Mukta Kirloskar

      Thank you for pointing it out, Giles. The problem is fixed.

      Jan 11, 2019 07:32