PATROL Agent is unable to connect to TrueSight Integration Service


PATROL Agent is unable to connect to TrueSight Integration Service due to missing Microsoft Visual C++ 2015 Redistributable

Issue

After installing or upgrading the Integration Service to version 11.3.04 or later, PATROL Agent is unable to connect to the Integration Service and displays the following error message in the TrueSightAgent_<hostname>_12124_3183.log file:

INFO  07/07 05:33:23
Agent               
[main] 860001 java.lang.UnsatisfiedLinkError: C:\Program Files\BMC
Software\TrueSight\pw\patrol\bin\acmmls32_v2140_64.dll: Can't find dependent
libraries

Probable Cause

Integration Service is unable to find Microsoft Visual C++ 2015 Redistributable, and therefore it fails to respond to the PATROL Agent communication requests.

Resolution

Do the following to resolve this issue:

  1. Install the Microsoft Visual C++ 2015 Redistributable on the machine on which the local or the remote Integration Service is installed. 
  2. Restart the Integration Service (local/remote).

A fresh instance of a PATROL Agent fails to connect to TrueSight Integration Service after it is upgraded due to a missing configuration property

Issue

If you have configured a remote cell for the agent controller process, and upgrade the Integration Service to version 11.3.04 or later, a fresh instance of a PATROL Agent fails to connect to this upgraded Integration Service and its status is shown as Connecting on the TrueSight console. The following error message is displayed in the Truesight.log file of the Infrastructure Management server: 

ERROR 05/06 09:48:11 pronet_cntl [PatrolAgentAddMsg_4] Exception while creating mo:AP0_100_50006420
java.lang.Exception: <<<mcell is not running: device operation failed>>>

Probable Cause
The PATROL Agent fails to connect to the Integration Service as the configuration property pronet.pronet_cntl.cellservice.Remotecell.connection.enabled is not defined.

Resolution

Do the following to fix the issue:

  1. Log in to the Infrastructure Management server.
  2. Go to the <TrueSight Infrastructure Management installation directory>\pw\custom\conf directory.
  3. Using a text editor, open the pronet.conf file, and add the following entries: 

    pronet.pronet_cntl.cellservice.Remotecell.connection.enabled=true
  4. Restart the Infrastructure Management server.


 

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