This documentation supports the 18.08 version of Remedy Deployment.

To view the latest version, select the version from the Product version menu.

Additional BMC Atrium Core requirements

This section describes requirements for installing the BMC Atrium Core and BMC Atrium Web Services Infrastructure component. 

BMC Atrium Core requirements

The following table lists additional software that must be installed on your computer before you install BMC Atrium Core:

RequirementUNIXWindows

BMC Atrium Core relies on the BMC Remedy AR System for database management system and web/application server support. Please refer to the Compatibility matrix for specifics of the supported versions of the AR System server.

Note: Starting with version 9.x, the Java-based BMC Atrium CMDB requires a Java-based AR System server.

  

Adobe Flash, required for clients using BMC Atrium Core Console (available at http://www.adobe.com/products/flashplayer/ )

Note: To enable you to properly view BMC Atrium Core UI and Flashboards, Adobe Flash Player 10 or later is required.

Adobe Flash Player version 10 and later

Adobe Flash Player version 9 and later

Security requirements

Same as for BMC Remedy AR System. See Security in the BMC Remedy AR System online documentation.

BMC Remedy Mid Tier
 

Same as for BMC Remedy AR System. See Security in the BMC Remedy AR System online documentation.

BMC Atrium Core Web Services requirements

This section describes prerequisites for installing the BMC Atrium Web Services Infrastructure and UDDI Registry components.

Note

Java SE 8_u45 and higher is supported. Older versions are not supported.

  • The Web Services Infrastructure component requires Apache Tomcat server version 7.0 or later (which is itself a prerequisite for accessing the BMC Atrium Core Console).

  • The Tomcat server must be configured to use JRE version 1.7.0_55 or later.

The Tomcat server on which the Web Services Infrastructure component is installed must have client authentication set to False. Otherwise, the BMC Atrium Core installer cannot validate the installation of the BMC Atrium Web Services components.

Recommendation

  • To avoid memory issues, BMC recommends that you do not install BMC Atrium Core Web Services and BMC Remedy Mid Tier on the same Tomcat server that is installed with 32-bit Java. You can install them on the same server if the server uses 64-bit Java.
  • For releases 9.1.04 and later, the Dashboard Utility is used to calculate Datasources statistics and KPIs that are displayed on the UI. This utility might require increased memory. By default, this utility is allocated a space of 1536 MB.


The Web Services Infrastructure component uses the bundled Apache Axis2 Web Archive (WAR) version 1.5.1. For information about the distributions that are included in the Apache Axis2 WAR, see Apache Axis2 and BMC Atrium Core Web Services  multiin the BMC Atrium Core documentation.

  • UDDI Registry uses Apache jUDDI Server version 3.0.4, which supports Universal Description Discovery and Integration (UDDI). The Apache Derby database, which runs inside the Tomcat server, is embedded in the jUDDI Server.
Was this page helpful? Yes No Submitting... Thank you

Comments