Integration Service system requirements


Before installing the Integration Service, review the following requirements:

Hardware requirements

When determining the size of your environment for data event management and impact event management, consider the following hardware requirements for the Integration Service.

Note

  • The recommended hardware requirements are valid, whether you use physical or virtual machines.
  • If you are installing the Integration Service in a virtual environment, ensure to reserve CPU and memory resources.
  • You can install a new version of the Integration Service on the same system as the previous Integration Service, provided the system has sufficient disk space to accommodate both versions.
EnvironmentConfiguration ItemData event management and impact event management
Small

Platform

CPU: 2 vCPU, Frequency: 2.2 GHz

RAM

4 GB

Storage

50 GB of available disk space

Medium

Platform

CPU: 4 vCPU, Frequency: 2.2GHz

RAM

8 GB

Storage

50 GB of available disk space

Large

Platform

CPU: 4 vCPU, Frequency: 2.2GHz

RAM

8 GB

Storage

50 GB of available disk space

Operating system requirements

Support for third-party products

To receive full support for a BMC product, you must have such product installed in a supported environment, as specified in the BMC product documentation. If a third-party vendor cancels support for one of its products (such as an operating system or subsystem), and that third-party product integrates or interacts with the BMC product you have licensed, you must upgrade to a supported version of that third-party product before BMC Customer Support can provide you with support for the affected BMC product. For further information, view BMC's product support policy. Open link

Microsoft Windows

ComponentRequirement
User RightsAdministrative privileges
Supported versions of Microsoft Windows

11.3.04/11.3.0511.3.06

Microsoft Windows 2019

  • Microsoft Windows 2019 Standard Edition (64-bit)
  • Microsoft Windows 2019 Datacenter Edition (64-bit)

Microsoft Windows 2016

  • Microsoft Windows 2016 Standard Edition (64-bit)
  • Microsoft Windows 2016 Datacenter Edition (64-bit)

Microsoft Windows 2012 

  • Microsoft Windows 2012 R2 Standard Edition (64-bit)  
  • Microsoft Windows 2012 R2 Datacenter Edition (64-bit)
  • Microsoft Windows 2012 Standard Edition (64-bit)  
  • Microsoft Windows 2012 Datacenter Edition (64-bit)  

Microsoft Windows 2022

  • Microsoft Windows 2022 Standard Edition (64-bit)
  • Microsoft Windows 2022 Datacenter Edition (64-bit)

Microsoft Windows 2019

  • Microsoft Windows 2019 Standard Edition (64-bit)
  • Microsoft Windows 2019 Datacenter Edition (64-bit)

Microsoft Windows 2016

  • Microsoft Windows 2016 Standard Edition (64-bit)
  • Microsoft Windows 2016 Datacenter Edition (64-bit)

Microsoft Windows 2012 

  • Microsoft Windows 2012 R2 Standard Edition (64-bit)  
  • Microsoft Windows 2012 R2 Datacenter Edition (64-bit)
  • Microsoft Windows 2012 Standard Edition (64-bit)  
  • Microsoft Windows 2012 Datacenter Edition (64-bit)  

Note: You must disable the User Access Control for Windows.

Linux

ComponentRequirement
User Rightsroot privileges
Supported versions of Linux

11.3.0411.3.0511.3.05.00111.3.06
  • Red Hat Enterprise Linux 7.x, 8.x (up to 8.8), and 9.x (up to 9.2)

  • SUSE Linux Enterprise Server 12.x (up to SP5) and 15 (up to SP5)
  • Oracle Linux Server 7.x, 8.x (up to 8.7), and 9.x (up to 9.2)
  • Red Hat Enterprise Linux 7.x, and  8.1, 8.2, 8.3
  • SUSE Linux Enterprise Server 12.x, and 15 (SP1,SP2) 
  • Oracle Linux Server 7.x
  • Red Hat Enterprise Linux 7.x, 8.x (up to 8.8), and 9.x (up to 9.2)
  • SUSE Linux Enterprise Server 12.x (up to SP5) and 15 (up to SP5)
  • Oracle Linux Server 7.x, 8.x (up to 8.7), and 9.x (up to 9.2)
  • Red Hat Enterprise Linux 7.x, 8.x (up to 8.8), and 9.x (up to 9.2)
  • SUSE Linux Enterprise Server 12.x (up to SP5) and 15 (up to SP5) 
  • Oracle Linux Server 7.x, 8.x (up to 8.7), and 9.x (up to 9.2)

Important

  • For RHEL 8.x supported installation,  you must follow the Technical bulletin Open link .
  • For RHEL, an Operating System upgrade is not supported. For example, you cannot upgrade RHEL from version 7.x to 8.x. An Operating System upgrade is supported only for minor versions, such as from 8.1 to 8.4.

UmaskUmask must be set to 022.

 

On Red Hat Enterprise Linux, the following libraries must be installed before installing the Integration Service.   

The preferred method to add any missing libraries is to use the yum command to fetch the necessary library packages from the RHN (Red Hat Network) repository via the internet.  To use this method, a Red Hat subscription is needed. Register the system by clicking System->Administration->Red Hat Subscription Manager in the menu on the server itself.  After registering the system, you can use "yum install" to download and install the required libraries from the RHN.

Library

Command to install the library on Red Hat Enterprise Linux 7.x

Command to install the library on Red Hat Enterprise Linux 8.x and 9.x

Command to install the library on SUSE

libXtst (64-bit)

yum install libXtst.x86_64
            libXtst-1.0.1-3.1
            libX11-devel-1.0.3-11.el5
yum install libXtst.x86_64
            libXtst
            libX11-devel

N/A


glibc (32-bit)

glibc (64-bit)

yum install glibc.i686 glibc.x86_64
             glibc-devel-2.5-65
yum install glibc.i686 glibc.x86_64
             glibc-devel

zypper install glibc-32bit glibc

libstdc++ (64-bit)

yum install libstdc++.x86_64
yum install libstdc++.x86_64

zypper install libstdc++

compat-libstdc++-33 (64-bit)

yum install compat-libstdc++-33.x86_64 
N/A

zypper install libstdc++33 

pam (64-bit)

yum install pam.x86_64
yum install pam.x86_64

zypper install pam

fontconfig (64-bit)yum install -y dejavu-serif-fontsyum install -y dejavu-serif-fontsN/A

libnsl (32-bit)

libnsl (64-bit)

N/A

yum install libnsl.i686 libnsl.x86_64

Only for 11.3.05 version

yum install libnsl-2.28-127.el8.i686
libnsl-2.28-127.el8.x86_64

N/A
libxcrypt (32-bit)

N/A

yum install libxcrypt.i686
N/A
N/A

N/A

Only for RHEL 9.X 

Follow the below steps before you install:

  1. Run the following commands

    #yum install libnsl2
    #cd /lib64/
    #ln -s libnsl.so.3.0.0 libnsl.so.2
    #yum install libcrypt.so.1
    
    
  2. Check if /etc/init.d is avaialble, if not create symbolic link of /etc/init.d to /etc/rc.d/init.d

    #cd /etc
    #ln -s rc.d/init.d  init.d
  3. Run command:
    #yum install chkconfig

For Remote Cell and Integration Services, only fresh install of 11.3.06 is supported on RHEL 9.x.

N/A

Note

  • To avoid errors while installing 32-bit libraries, BMC recommends that you install 32-bit libraries together with the 64-bit libraries.
  • After installing the libraries, run yum check to ensure that the libraries are not corrupt.

Guidelines and limitations for deployment

Follow these guidelines when planning the hardware deployment:

  • The load can be distributed across one or more Integration Services by keeping the total load on the server constant as per the deployment type. You can configure a maximum of 25 Integration Services per Infrastructure Management server.

  • You can configure a maximum of 500 PATROL Agents per Integration Service in a small deployment and 900 in medium and large deployments.
  • To distribute the load, you can configure up to three Integration Services on the same Integration Service host computer. For more information, see Sizing chart for multiple Integration Services running on the same Integration Service host.


Related topics

Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Ivy Zheng

    Why "Supported versions of Microsoft Windows" can't be shown here? Please check what's wrong and fix it ASAP...

    Oct 28, 2021 10:42
    1. Krutarth Mohakud

      Hi @Ivy, this is fixed. Thanks

      Oct 29, 2021 01:31
  2. Prabhat singh Pal

    Link is broken for Operating system requirement. Greeting below error.

    Page not found for multiexcerpt macro. The page: .System requirements for Presentation Server v11.3.04 was not found. Please check/update the page name used in the 'multiexcerpt-include' macro.

    Kindly fix it.

    Nov 30, 2021 12:18
    1. Krutarth Mohakud

      Hi Prabhat singh Pal , this is fixed. Thanks

      Mar 03, 2022 12:55
  3. Nikhil Shetty

    you can check OS details for IS on https://customerapps.bmc.com/spac/o/welcome.html?F700002937=LPZTY.11.3.04

    Nov 30, 2021 03:26
  4. Amit Singh

    Still facing issue while "Page not found for multiexcerpt macro. The page: .System requirements for Presentation Server v11.3.04 was not found. Please check/update the page name used in the 'multiexcerpt-include' macro." under Supported versions of Microsoft Windows

    Mar 02, 2022 10:04
    1. Krutarth Mohakud

      Amit Singh , this is fixed. Thanks

      Mar 03, 2022 12:54
  5. Mayuri Rathi

    Important

    For RHEL 8.x supported installation, you must follow the Technical bulletin . link broken for technical bulletin

    Jul 15, 2022 07:29
    1. Krutarth Mohakud

      HiMayuri Rathi - I have fixed this. Thanks

      Jul 15, 2022 07:47
  6. David Taggart

    "Supported versions of Linux" info missing. The page .System requirements for Presentation Server v11.3.05.001 was not found -- Please check/update the page name used in the MultiExcerpt-Include macro

    Jun 22, 2023 11:29
    1. Mukta Kirloskar

      Thank you for your comment. We have fixed this.

      Dec 27, 2023 01:36