Remedy SSO system requirements for TrueSight Operations Management

Before installing the Remedy Single Sign-On (Remedy SSO) Server, which is a prerequisite product for the TrueSight Presentation Server, ensure that its target system meets the following requirements.

Before you proceed, consult the Deployment options for Remedy SSO with TrueSight Operations Management topic to determine whether to use the Remedy installer or the TrueSight installer for Remedy SSO for installing Remedy SSO.

Note

If you have an existing Remedy SSO server installation (must be one of the supported versions) in your environment, which you want to configure with the TrueSight Presentation Server installation and do not plan to freshly install or upgrade Remedy SSO, do the following:

System requirements for Remedy SSO installer

 System requirements for Remedy SSO installer

Remedy SSO version note

BMC recommends that you refer to the product documentation corresponding to the version of Remedy SSO that you are planning to install and configure with the TrueSight Operations Management.

  • System requirements version 19.11

  • System requirements version 19.08

  • System requirements version 19.05

  • System requirements version 19.02


System requirements for TrueSight installer for Remedy SSO

Note

  • There is no TrueSight installer for Remedy SSO available for version 11.3.02 or later. It is available for versions 11.0.00 and 11.3.01 only. You can choose to install using the TrueSight installer for Remedy SSO version 11.3.01 and then based on your license entitlement upgrade to any of the supported versions of the Remedy SSO server using the Remedy SSO installer.
  • Alternatively, you can directly install any of the supported versions of the Remedy SSO server using the Remedy SSO installer.
  • If you have installed and configured TrueSight installer for Remedy SSO (consolidated installer) version 11.0 or 11.3.01 and plan to upgrade to Remedy SSO to 18.11 or later, ensure that you have performed the steps mentioned in Best practices before upgrading Remedy SSO section in the Preparing to upgrade Remedy Single Sign-On topic.
 System requirements for TrueSight installer for Remedy SSO


Operating System and Platform requirements

Support for third-party products

To receive full support for a BMC product, you must have such product installed in a supported environment, as specified in the BMC product documentation. If a third-party vendor cancels support for one of its products (such as an operating system or subsystem), and that third-party product integrates or interacts with the BMC product you have licensed, you must upgrade to a supported version of that third-party product before BMC Customer Support can provide you with support for the affected BMC product. For further information, see BMC's product support policy.

The Remedy Single Sign-On server is supported on the following operating systems. 

ResourceRequirements
Platform64-bit x86 compatible PC
Operating systems

Microsoft Windows 2019

  • Microsoft Windows 2019 Standard Edition (64-bit)
  • Microsoft Windows 2019 Datacenter Edition (64-bit)

Microsoft Windows 2016

  • Microsoft Windows 2016 Standard Edition (64-bit)
  • Microsoft Windows 2016 Datacenter Edition (64-bit)

Microsoft Windows 2012 

  • Microsoft Windows 2012 R2 Standard Edition (64-bit)  
  • Microsoft Windows 2012 R2 Datacenter Edition (64-bit)
  • Microsoft Windows 2012 Standard Edition (64-bit)  
  • Microsoft Windows 2012 Datacenter Edition (64-bit)  

Microsoft Windows 2008

  • Microsoft Windows 2008 R2 Standard Edition (64-bit)
  • Microsoft Windows 2008 R2 Datacenter Edition (64-bit)
  • Microsoft Windows 2008 R2 Enterprise Edition (64-bit)

  • Red Hat Enterprise Linux 6.x and 7.x
  • SUSE Linux Enterprise Server 11.x, 12.x, and 15
  • Oracle Linux Server 6.x and 7.x

Disk space

1 GB

An additional 7-10 GB of space is recommended for log file growth, depending on the volume of users and products that are integrated with the Remedy Single Sign-On Server.

RAM2 GB

Note

On a Linux setup, ensure that glibc-2.12.x86_64 (or later versions) is installed on the computer where you plan to install Remedy Single Sign-On.

Supported database

PostgreSQL 9.6.3

Database and High-Availability environment

Important: The PostgreSQL database bundled with TrueSight installer for Remedy SSO is not applicable for a HA environment. For setting up a high-availability environment with TrueSight installer for Remedy SSO, you must have installed and configured an external PostgreSQL database.



Firewalls

  • Remedy SSO Server uses the HTTP or HTTPS protocol configured on Tomcat. The ports configured on Tomcat must be accessible from the host machines where the other TrueSight (integrated) products such as TrueSight Infrastructure Management and TrueSight Presentation Server are installed.
  • Remedy SSO Server installed using the TrueSight installer for Remedy SSO uses the PostgreSQL database and therefore the database ports must be accessible from the Remedy SSO Server host.

Where to go from here

Installing Remedy SSO.

Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Cassie Derrick

    Can you tell me which version of RSSO is compatible with TSOM. I don't know where I'm to find that information. It's not on Product Availability & Compatibility pages nor the Architecture Compatibility Modeler.

    Jul 31, 2019 03:16
    1. Harihara Subramanian

      Hi Cassie Derrick,

      See this topic Remedy Single Sign-On at-a-glance for the supported version. I am adding a reference link from this topic too. However, the link Preparing to upgrade Remedy Single Sign-On too contains the supported version number. One topic above this topic (in the flow) contains the version info.

      Deployment options for Remedy SSO with TrueSight Operations Management



      Aug 01, 2019 06:22
  2. Giles Day

    Is 1 vcpu is enough?

    Dec 24, 2019 07:29
    1. Harihara Subramanian

      Hello Giles Day ,

      No such recommendations for Remedy SSO as we do not have such requirements. The Remedy SSO runs on Tomcat server, and all minimum hardware requirements depend on Tomcat.


      Thanks,

      Hari

      Dec 27, 2019 04:49