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Troubleshooting performance issues with archiving


When you observe performance issues with the archiving process, follow the appropriate logging and troubleshooting steps to either resolve a problem or create a BMC Support case.

Symptoms

Archiving Operation is taking too long to process the records.

Scope

  • Individual Archive Operations are taking longer time than past runs.
  • The total archiving process takes longer time.

Resolution

The following table describes the tasks performed to ensure that the Archiving process is running correctly:

Important

To check whether the Archiving Operation is still processing records, enable the archiving logging.


Step

Task

Description

1

Review the number of records being archived and the number of threads used to archive records.

Cause:

When there are more records to process than before, the Archiving process takes a longer time to complete. As a company becomes more mature in the ITSM process, they create more records and have more assets and relationships between their data. As a result, more records get archived over time.

To check whether the archiving process is taking longer time because of large number of records, perform the following steps:

  1. From the Application menu, select AR System Administration > AR System Archive Manager console.
  2. In the Search box, run the query Create date for a given time frame. We recommend you to set the time frame to one week.
    You will get the count of records for the week.
  3. Run the Create date query again for a period of time when the archiving process was working as expected.
    If you find a significant difference between the records archived during a previous time frame and the most recent time frame, the increased time to process can be explained by the increase in the number of records.

Resolution:

Add additional threads to your Archiving Operation. Configure the threads by setting the following component in CCS:

Component

Setting

Description

com.bmc.arsys.server.shared
Num-Archive-Threads

Default: 1

This setting controls the number of threads used to archive records. This setting is a backend operation and will not affect users. But setting this number too high will cause excessive load on the database server.

2

Review the Individual SQL Queries.

Cause:

When the Archiving Operation evaluates records to ensure they meet the archive qualification, the SQL statements used to evaluate the records can take a long time on some databases during certain scenarios.

Enable the Archiving and SQL logs to check whether the archiving is taking longer time because of the SQL queries. Run the SQL logs through the AR Log Analyzer to identify poor running SQL queries.

Resolution:

The administrator must engage a Database administrator (DBA) to ensure that the database is healthy and help troubleshoot and tune the SQL query. The DBA should ensure that:

  • The database resources are sufficient for the operation.
  • Appropriate Indexes have been applied through Developer Studio on the main form being archived.
  • The database is not encountering any errors in processing.
  • The database statistics are updated.
  • Any other database maintenance operations have been completed.
  • The queries in question are tuned effectively.

3

Review the system resources.

Cause:

While archiving records, the available system resources (CPU and Memory) can become very low. Occasionally, it might not be noticeable that a significant reduction in archiving performance has occurred. Additionally, you might notice that this adversely affects other operations the system might be trying to process.

Resolution:

  • Reduce the number of threads assigned to your Archiving Operation. Perform the steps given in Step 1.
  • Work with a system administrator to increase the resources available to the system.
  • Move any other operations like FTS, or Approvals to another system to distribute the load.

 

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