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Troubleshooting issues with the archiving records


When you observe issues with the records to be archived, follow the appropriate logging and troubleshooting steps to either resolve a problem or create a BMC Support case.

Symptoms

  • Records are not being moved to the archive form.
  • Specific records are failing to be archived after several attempts.

Scope

A small number of records in the system are failing to archive and other records of the same type are processing successfully.

Resolution

The following table describes the several tasks that can be reviewed to ensure that the Archiving process is archiving all the records:

Step

Task

Description

1

Review the records to be archived and their qualifications

Cause:

The record to be archived does not meet the qualification.

Each policy has a qualification. The policy evaluates each record based on the qualification in the parent form. For example, the Incident Management Archive Policy is defined through the HPD:Help Desk form, which has a qualification that has the operators as Status and Do Not Archive, in addition to the Create Date field, which is the default for all Archive Policies. All three fields have to meet the defined criteria. The policy must not have qualifications that are too restrictive such as ................

Resolution:

  1. Enter the following URL to open the HPD:Help Desk form:
    http://<servername>:<port>/arsys/forms/<serverName>/HPD:Help Desk
  2. Check the Archive Qualification in the Parent form definition.
  3. Modify the qualifications to be less restrictive and meet the requirement of your data archiving criteria. For example, ...........

2

Review the Do Not Archive flag


Cause:

The Do Not Archive flag is enabled for the record to be archived.

Some forms have a Do Not Archive field specifically designed for the archiving operation. This field is included on these forms to ensure that a record is not archived, in case of an audit or an unfinished ticket. If the flag is enabled, OOTB qualifications will not trigger.

Resolution:

Ensure that the Do Not Archive field is not selected on the record to be archived. In some cases, you might need to ensure that the parent record does not have the field marked.

3

Review the workflow operations of the records to be archived.


Cause:

The record to be archived does not pass certain workflow operations and is giving an error.

Archive forms do not have any workflow that applies to them. But during the qualification, copy and delete phases, workflow gets applied to the regular form. So if there are any workflow objects that might cause a issue, it gives and error and prevents the Archiving operation, forcing a rollback.

You can observer this error by enabling the Archiving+SQL+Filter logging. Use the Trace ID <TrID> to better track the workflow of the archive.

Resolution:

  1. Enable the Archiving+SQL+Filter logging and review any custom workflow objects. 
  2. If required, modify the data in the record or modify the workflow object.

 

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