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Troubleshooting archiving server issues


When you observe issues with the selected server to run the archiving process, follow the appropriate logging and troubleshooting steps to either resolve a problem or create a BMC Support case.

Symptoms

  • The Archiving Operation is not running on the selected server.
  • A server with ranking other than 1 for the Archiving Operation is running the archiving process.
  • Poor performance with the other operations on the server.
  • Alerts of processes being down.
  • Alerts of resources being used unexpectedly.

Scope

A server not expected to process the Archive Operation is processing the archive tickets.

Resolution

The following table describes the several tasks that can be reviewed to ensure that the Archiving Operation is working on the correct server:

Important

To check whether the Archiving Operation is working on the correct server, enable the archiving logging on the server ranked for archiving and the server on which the archiving process is running unexpectedly.


Step

Task

Description

1

Review the Server Group Operation Ranking form

Cause:

In the AR System Server Group Operation Ranking form, if the expected server is not configured for the Archiving Operation, another server may perform the archiving operation.

The rank of the expected server may change due to data backup/restore, a recent change, or even a brief alteration during a routine maintenance operation.

Resolution:

  1. Enter the following URL to open the AR System Server Group Operation Ranking form:
    http://<servername>:<port>/arsys/forms/<serverName>/AR+System+Server+Group+Operation+Ranking
  2. Update the rank of the servers in question in the correct order for Archiving, and save each record. 
  3. Click Refresh Ranking button at the bottom of the page after the last record has been updated. For more information, see Remedy ITSM - Archive best practice.

2

Check if the server ranked 1 is running


Cause:

The Archiving Operation fails if the server ranked 1 for Archiving fails and is not running. The server may fail due to issues like network connectivity, resource constraints, or other issues.

Resolution:

  • Restart the server in question. If the server does not start, review the armonitor.log, arerror.log, and ardebug.log files for any additional error messages and troubleshoot the startup failure.
  • If the server fails frequently, enable the API+Filter+SQL+ESC logs along with Archive Server Group Thread logs. Analyze each of the logs to ensure that a thread is not stuck for long periods of time.
  • Perform regular thread dumps of the AR Server process to analyze the issues for the blocked threads.

If you confirm that the server is failing, you must carry out extensive testing and troubleshooting to determine the exact root cause. You must constantly perform system monitoring, logging, and thread dumps until the issue can be adequately reproduced and diagnosed.

3

Contact BMC Support

If you cannot determine the issue, obtain the logs given in the preceding step and perform the following steps:

  • After you obtain the information from the logs, validate the errors on a previous working configuration or another working system.
  • Open a new BMC Support Case and provide the preceding information along with the requested logs showing the behavior.

 

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