TrueSight console loading and performance issues
The TrueSight Presentation Server console also known as TrueSight console is hosted on the Presentation Server.
This troubleshooting topic helps you to troubleshoot the problem or to collect the appropriate log data to create a BMC Support case.
Symptom | Solution |
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Intermittent: TrueSight console stops responding for a short duration.
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In the following few scenarios blank screen is displayed on the TrueSight console:
| Do one of the following:
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| Manual refresh of browser (reloading the page) resolves the issue. |
TrueSight Presentation Server is not showing up
Issue
When starting the individual processes the database processes are not showing up and due to this other TrueSight Presentation Server processes also get terminated.
Cause
In any case, if pg_logs folder does not exists at <TrueSight Presentation Server Install Location>\truesightpserver\logs folder then the new postgresql database (v13.2) process does not show up.
While cleaning old logs if user deletes the folder pg_logs under TrueSight Presentation Server logs directory, then this issue occurs.
Solution
While cleaning the logs, don't delete the pg_logs folder.
If you have deleted the folder, create the folder.
Diagnosing and reporting an issue
Task | Action | Steps | Reference |
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1 | Troubleshoot | If console is not responding or observing slow performance after performing certain actions inTrueSight console, do the following:
| Refer to Knowledge Article number000335333 (TrueSight Presentation Server (TSPS) is taking a long time to start and there are performance issues with TSPS) |
2 | Collect diagnostics and report to BMC Customer Support |
tssh logger debug on -n AppContextApplication
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