Resolving an unknown application
If an agent cannot detect an application, the application name is displayed as UNKNOWN_APPLICATION.
Issue
The list of applications (Monitoring > Applications) shows an application named UNKNOWN_APPLICATION.
Probable cause
App Visibility agents are not installed on all the servers that are employed as the first backend tiers (usually a Web tier).
The application name for an automatically discovered application is based on requests that are received by the first backend tier, that is, the tier to which end-user clients directly connect. Automatic application discovery is supported only for end-user clients that use HTTP or HTTPS to connect to the first backend tier.
If the first backend tier communicates with subsequent tiers using an unsupported protocol, or an App Visibility agent is on the subsequent tier but not on the first tier, then the App Visibility agent on the subsequent tier cannot identify the application, and therefore names it UNKNOWN_APPLICATION.
Resolution
Install App Visibility agents on all servers that are employed as the first backend tier (usually a Web tier), and monitor only HTTP or HTTPS requests to a Web tier.
Related topics
App-Visibility-system-requirements
Installing-App-Visibility-components
Understanding-an-unknown-node-in-an-automatically-discovered-application-model