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Enabling communication between App Visibility agents and server components


If an application server on which the App Visibility agent is installed uses different ciphers than those enabled by default by the App Visibility portal and collector, communication between the agent and the server is not enabled.

Issue

The App Visibility agent cannot connect to the portal and collector.

Probable cause

By default, the portal and collector do not have any ciphers in common with those supported by the application server.

Resolution

You can update the tomcat.ciphers property for the portal and collector to enable data collection from the agent.

  1. Stop the service or services.
  2. Open the properties file for each component in a text editor:
    • Portal: installationDirectory\portal\properties\portal.properties
    • Collector: installationDirectory\collector\properties\collector.properties
  3. For each component property file, add the required cipher to the tomcat.ciphers property.
  4. Restart the service or services.

Related topics

App-Visibility-agent-for-NET-requires-Windows-2003-security-patch

Enabling-SSL-3-0-for-App-Visibility-Manager

 

 

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