Troubleshooting devices


This topic lists troubleshooting tips that you can use if you run into problems when using devices.

Device is not created

Device does not exist in your network. 

A device that is already on your list of devices does not exist in your network, or DNS cannot translate the system name to the IP address. 

Verify that you have not already added the device. Ping the device to see whether the device is on the network. Use the IP address instead of the system name. Close and open the Administration Console.

Graphs have broken lines (gaps)

Gaps in graphs can occur when you stop and start the server process, when Collect Data is not selected, or when the polling speed is set to high. 

The polling speed is set to high for the graph. Gaps in graphs can also occur when you stop and restart the BMC TrueSight Infrastructure Management Server processes or when Collect Data is not selected. No data is collected during the period when the processes are stopped or when Collect Data is not selected. 

Edit the file for the graph and lower the speed setting to a value not higher than 9600.

Devices cannot share an IP address

Each device on a server must have a unique IP address. 

You cannot create two devices on a BMC TrueSight Infrastructure Management Server with the same IP address. 

Delete all but one of the devices that share an IP address, and re-add those devices by using new IP addresses for each.

Warning

Deleting devices also deletes the data of those devices.

The device count between the Presentation Server and the Infrastructure Management server do not match

Issue

The number of devices displayed in the TrueSight console and the Infrastructure Management operator console do not match.

Cause

Devices are synced from Infrastructure Management to the Presentation Server. When devices are deleted through any operation on the operator console, they continue to exist in the Presentation Server as stale devices.

Resolution

On the Presentation Server, run the following command from the installationDirectory\truesightpserver\bin folder:

tssh device delete all

This command deletes all stale devices from the Presentation Server.

PATROL Agent is registered with short name despite the FQDN being known

Issue

Both TrueSight Infrastructure Management and TrueSight Presentation Server consoles display a PATROL Agent as short name (hostname only, no domain), despite the FQDN of the PATROL Agent server being known.

Cause

There are some KMs that contain a short name reference that overrides the known FQDN in TrueSight.

Resolution

Add the following properties in the installationDirectory/pw/custom/conf/pronet.conf file and restart the Infrastructure Management server:



pronet.preferPublishHostNameForPAConsolidation=true

This property controls the consolidation of PATROL Agents using the published host name. By default, the consolidation is done with the FQDN.

pronet.agentcontroller.autosync.devicename.overwrite=false

This property consolidates PATROL Agents using the FQDN instead of the short name.


 

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