Enabling communication between Diagnostics Agents and Server components


If an application server on which the Application Diagnostics Agent is installed uses different ciphers than those enabled by default by the Application Diagnostics Portal and Collector, communication between the Agent and the Server is not enabled.

Issue

The Application Diagnostics Agent cannot connect to the portal and collector.

Probable cause

By default, the portal and collector do not have any ciphers in common with those supported by the application server.

Resolution

You can update the tomcat.ciphers property for the portal and collector to enable data collection from the agent.

  1. Stop the service or services.
  2. Open the properties file for each component in a text editor:
    • Portal: installationDirectory\portal\properties\portal.properties
    • Collector: installationDirectory\collector\properties\collector.properties
  3. For each component property file, add the required cipher to the tomcat.ciphers property.
  4. Restart the service or services.

Related topic

Patch-available-for-SSL-3-0-POODLE-security-vulnerability-for-Application-Diagnostics

 

 

Tip: For faster searching, add an asterisk to the end of your partial query. Example: cert*

BMC TrueSight App Visibility Manager 2.6