Troubleshooting Collection Agent configuration issues


This section provides information about troubleshooting problems that you could encounter when you configure a Collection Agent.

This page contains the following topics:

Scenario

After configuring Collection Agents by using PATROL for IT Data Analytics, the host details are not displayed on IT Data Analytics, under the Administration > Host page.

Cause

This issue can occur if the Collection Agent configured is not connected with the Collection Station.This can happen in one of the following scenarios:

  • If the Java Runtime Environment (JRE) installed on the PATROL Agent computer is not supported.
  • if no JRE is installed on the PATROL Agent computer.

Solution

Ensure that a supported JRE version is installed on the PATROL Agent computer and the correct JAVA path is updated in the monitoring policy created on TrueSight Presentation Server.

To verify if a supported JRE is installed, follow these steps:

  1. Navigate to the %PATROL_HOME%\bww\udc\ path and verify if the logs folder is created.

    • If the  logs folder does not exist, it means that no JRE is present on the PATROL Agent computer.  
    • If the  logs folder exists, it is possible that the JRE version installed on the PATROL Agent computer is not supported.

2. The following step applies if the JAVA process is not launched.


    • Navigate to %PATROL_HOME%\log\.
    • In the PatrolAgent-<host>-<port> file, verify the message related to JRE. For more information, see System-requirements.

 

 

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