Troubleshooting the installation
This topic provides information on resolving issues that may occur during the installation and uninstallation processes.
BMC Application Diagnostics Agent is not installed
Issue
BMC Application Diagnostics Agent installation starts and exits immediately, and the BMC Application Diagnostics Agent is not installed.
Probable cause
User does not have write permissions in the folder where the BMC Application Diagnostics Agent installation files are located.
Resolution
Assign a user with write permissions on the folder where the BMC Application Diagnostics Agent installation is run from.
Error on a Linux computer when installing to a path name that contains spaces
Issue
Installation does not complete successfully on a Linux computer when the installation path name contains spaces.
Probable cause
MySQL does not support installation on a path name that contains spaces.
Resolution
The installation path name must not contain spaces.
Files remain after uninstalling BMC Application Diagnostics
Issue
Files may exist after the uninstallation process.
Probable cause
The uninstallation process has not deleted some files.
Resolution
Delete temporary files using the following procedure.
For Windows:
- Restart the machine and delete the files.
For Linux:
In the event that files were not deleted because the services are still running, stop the services with the following commands:
service adop_portal stop
service adop_collector stopRemove the services scripts with the following commands:
delete /etc/init.d/adop_portal
delete /etc/init.d/adop_collector- Change directory to the services start script directory, for example cd /etc/init.d/rc.d/rc3.d
- Remove the files that end with the extension adop_portal and adop_collector, for example, delete /etc/init.d/rc.d/rc3.d/*adop_portal
- Delete any files that may still exist in your installation directory.