Edit permission issues
The following issues may occur as a result of insufficient permissions.
Cannot save the BMC Application Diagnostics Portal address
Issue
Cannot save the BMC Application Diagnostics Portal address.
Probable causes
- User has insufficient permissions to edit properties file.
- Properties file is protected (read only).
Resolution
- Assign user with edit permissions on the relevant folder (root or SUDO).
- Log on to the Operating System and either set file readable or edit the properties file manually.
Access Denied error when running with WebSphere
Issue
The BMC Application Diagnostics Agent log reflects Access Denied error entries when running with WebSphere.
Probable cause
The Agent does not have sufficient permissions.
Resolution
Edit the server.policy.
java.security.AccessControlException: Access denied exceptions
Issue
The BMC Application Diagnostics Agent does not work correctly and java.security.AccessControlException: Access denied exceptions are displayed in log files.
Probable cause
Relevant permissions have not been granted on the Java 2 security provider and application server type.
Resolution
Grant Java 2 permissions. See Granting-Java-2-permissions-to-the-agent.
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