Troubleshooting the installation
This topic provides information on resolving issues that may occur during the installation and uninstallation processes.
BMC Application Diagnostics Agent is not installed
Issue
BMC Application Diagnostics Agent installation starts and exits immediately, and the BMC Application Diagnostics Agent is not installed.
Probable cause
User does not have write permissions in the folder where the BMC Application Diagnostics Agent installation files are located.
Resolution
Assign a user with write permissions on the folder where the BMC Application Diagnostics Agent installation is run from. |
Temporary files remain after uninstalling BMC Application Diagnostics
Issue
Temporary files exist after following the uninstallation process.
Probable cause
The uninstallation process has not deleted temporary files.
Resolution
Delete temporary files using the following procedure.
For Windows:
- Run gpedit.msc to open the Group Policy window.
- In Computer Configuration > Administrative Templates > Windows Components > Terminal Services > Temporary folders:
- Enable Do not use temp folders per session.
- Enable Do not delete temp folder upon exit.
- Restart the computer to apply this change.
For Linux:
From a Command Line Interface enter the following commands:
PortalServiceInstaller.exe delete PortalService