Edit permission issues


The following issues may occur as a result of insufficient permissions.

Cannot save the BMC Application Diagnostics Portal address

Issue

Cannot save the BMC Application Diagnostics Portal address.

Probable causes

  1. User has insufficient permissions to edit properties file.
  2. Properties file is protected (read only).

Resolution

  1. Assign user with edit permissions on the relevant folder (root or SUDO).
  2. Log on to the Operating System and either set file readable or edit the properties file manually.

Access Denied error when running with WebSphere

Issue

The BMC Application Diagnostics Agent log reflects Access Denied error entries when running with WebSphere.

Probable cause

The Agent does not have sufficient permissions.

Resolution

Edit the server.policy.

Warning

Note

Using copy and paste when editing the server.policy file causes encoding problems for WebSphere when reading and parsing the file. Hidden coding causes a mismatch between the source and the target. To prevent this first copy and paste into a simple text editor, and then copy and paste from the text editor.

java.security.AccessControlException: Access denied exceptions

Issue

The BMC Application Diagnostics Agent does not work correctly and java.security.AccessControlException: Access denied exceptions are displayed in log files.

Probable cause

Relevant permissions have not been granted on the Java 2 security provider and application server type.

Resolution

Grant Java 2 permissions. See Granting-Java-2-permissions-to-the-BMC-Application-Diagnostics-Agent.

 

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BMC Application Diagnostics 1.2