Note

 

This documentation supports the 20.15.01 version of Remedyforce.

To view the latest documentation, click

Performing actions on problems

You can perform additional actions on problem records by using the Actions and Agent Tools menus. You can view only the options that your system administrator has configured for your profile.

To perform actions on a problem

  1. Click the Remedyforce Console tab.
  2. Click View > Problems.
  3. From the list of problems, select the record on which you want to perform an action.
  4. On the Problem Details form, from the Actions or Agent Tools menu, select the appropriate option.
    For more information, see Actions menu options and Agent Tools menu options.
  5. Save the problem record.

Actions menu options

The following table lists the options that are available by default in the Actions menu for problems. Your system administrator can add custom actions and configure the Actions menu options based on profiles.

GoalSelect optionAdditional steps to be performedNotes
To add notes to a recordAdd Note

In the Add Note window, perform the following actions:

  1. Enter the note details.
  2. (Optional) In the Duration field, enter the time that you have spent on the action for which you are adding a note.
  3. Click Add.
Alternatively, you can also navigate to Record Details > Action History > New Note.
To add user-defined or system-defined actions to a recordNew ActionIn the Actions window, select the action that you want to add to the record. If you select the Notes action, a new browser window is displayed where you can enter additional notes.

The actions that you select are displayed in the Action History section on the Record Details page.

Alternatively, you can also navigate to Record Details > Action History > New Action.

To view the history of all actions that are performed on a record.View Action HistoryIn the Problem History window, view the list of actions that are performed for the record. Select an action to view more details.Alternatively, you can also navigate to Record Details > Action History > View Action History.

To add an attachment to a record

Note: You can add attachments to an problem record before and after saving a record.

Attach/View Files

In the Attach/View Files window, perform the following actions:

  1. To select the file that you want to attach to the problem, click Choose File.
  2. Select the file that you want to add and click Open. The selected file is attached to the record.
  3. To close the Attach/View Files window, click Close.

Note: In the Attach/View Files window, you can also view or delete the existing attachments.

Alternatively, you can also navigate to Record Details > Notes & Attachments > Attach File.

The size of an attachment cannot exceed 10 MB.

To interact with the client about the recordEmailFor more information, see Using email conversation.Not applicable
To request an approval for a recordSubmit for ApprovalFor more information, see Submitting records for approval.Alternatively, you can also navigate to Record Details > Approval History > Submit for Approval.
To create a record similar to an existing recordCloneFor more information, see Cloning problems.Not applicable
To close a record after it is resolvedCloseFor more information, see Closing problems.Not applicable
To reopen a record if the issue reported in the original problem still exists or the reported resolution did not resolve the problem and further work is neededReopenFor more information, Reopening problems.Not applicable
To create a PDF file of the record detailsPrint to PDFNot applicableTo add a specific field to the PDF output, contact your system administrator.
To print the record detailsPrintIn the new browser tab or window that is displayed, click Print This PageNot applicable

Agent Tools menu options

The following table lists the options that are available by default in the Agent Tools menu for problems. Your system administrator can add custom actions and configure the Agent Tools menu options based on profiles.

GoalSelect optionAdditional steps to be performedNotes
To search for information to resolve a recordKnowledge SearchFor more information, see Searching the knowledge base.Performing a knowledge search does not search in check box, Date/Time, or Number type fields.
To create a knowledge article and link it to the record to resolve similar issuesCreate Knowledge ArticlesFor more information, see Creating a knowledge article from a record.The knowledge articles that you create are displayed in the Linked Knowledge Articles section.
To view the configuration items that are linked to a recordCI ExplorerIn the CI Explorer window, click a configuration item to view the detailed information.
  • There is no limit on the number of CIs that you can link to a record; however, at a time, you can view only 150 linked CIs in the CI Explorer.
  • Each time you click a record from the CI Explorer page, the record opens in a new browser tab or window.
To view service targets linked to a recordService TargetsFor more information, see Viewing service targets for a record.If there are applicable service targets, the Service Targets option is enabled only after you save the record and BMC Remedyforce creates the service target transactions for the record.
To order tasks and change requestsProblem ManifestFor more information, see Configuring the sequence of linked records in the manifest.The manifest is available after you save a record. The manifest provides a tabular view of all the tasks and change requests that are linked to a record.

Related topic

Adding custom actions to the Actions or Agent Tools menus

Was this page helpful? Yes No Submitting... Thank you

Comments