Page tree

Unsupported content

 

This version of the documentation is no longer supported. However, the documentation is available for your convenience. You will not be able to leave comments.

Skip to end of metadata
Go to start of metadata

You use the /AgentSetup/ pconfigRequiresAuthentication variable to restrict client access to the agent configuration database. This variable is defined in the [parm90:AGENT] stanza of the patrol.conf file. You can use this variable to restrict access to the agent configuration database from the following clients:

  • pconfig
  • wpconfig
  • xpconfig
  • PATROL Configuration Manager (PCM)

All the PATROL Agents running on the system or sharing the patrol.conf file require authentication irrespective of the value set in the /AgentSetup/ pconfigRequiresAuthentication variable. After this variable is set or modified, you must restart the PATROL Agent.

Following are the valid values:

  • True — restrict access to the agent configuration database (recommended); If you set the value of the variable to true, the pconfig agent connections require a valid account.
  • False — no restriction on access to the agent configuration database (default value)

Note

When the requiresconfigauthentication variable is set to true, you can only use the wpconfig or xpconfig utility version 3.5.90 or later.

To use the wpconfig utility version 3.5.90, install PATROL Console for Microsoft Windows 3.5.90. To use the xpconfig utility version 3.5.90, install PATROL Console for UNIX 3.5.90. For more information about these PATROL consoles, see the BMC Performance Manager Console 7.8.00 Release Notes.