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Diagnostics Collector stops responding on a Linux OS


Issue

The BMC Application Diagnostics Collector installed on a Linux OS computer stops responding and data collection stops.

Probable cause

The computer with the Collector ran out of space, possibly due to logging by the MySQL Database. MySQL logging is disabled, by default, with new installations, but you might need to disable it manually after you upgrade to BMC Application Diagnostics 2.5.00.

Resolution

To make more room on the computer, try the following tasks:

  • Remove unnecessary files and clear temp directories.
  • Remove old log files from the installationDirectory/ADOP_DB/mysql-5.5.2-m2-linux-x86_64-glibc23/data directory. You can remove log files that are numbered.
  • Disable MySQL bin logging.

    Click to expand steps.
    1. On the computer with the Collector, run the following command to stop the Collector service. (If the Portal is installed on the same computer, stop the Portal, too.)
      service adop_portal stop
      service adop_collector stop
    2. Run the following command to stop the MySQL Database service:
      service adop_mysql stop
    3. Open the my.cnf file in a text editor.
      The file is located at installationDirectory/ADOP_DB/mysql-5.5.2-m2-linux-x86_64-glibc23/my.cnf.
    4. Locate the following line and mark it as comment by adding a hash mark (#) at the beginning of the line:
      Original: log-bin=mysql-bin
      Commented: # log-bin=mysql-bin
    5. Save the file.
    6. Start the services for MySQL, Portal, and Collector:
      service adop_mysql start
      service adop_portal start
      service adop_collector start

 

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BMC TrueSight App Visibility Manager 2.7