This documentation supports the 20.02 version of Remedy Deployment.
To view an earlier version, select the version from the Product version menu.

Software dependencies for Remedy AR system

You must have the appropriate software installed before you install Remedy Action Request System (AR System) features and clients. The following table lists the required software for each feature or client. (Blank cells indicate no software dependency.)

BMC Remedy AR System featureBMC Remedy AR SystemBMC Remedy Mid TierWeb app serverJava Runtime EnvironmentMail server
  • Clients
  • BMC Developer Studio
  • BMC Remedy Data Import

(tick)



(tick)


BMC Remedy Email Engine

(tick)



(tick)

(tick)

BMC Remedy Flashboards

(tick)

(tick)


(tick)


BMC Remedy Mid Tier

(tick)


(tick)

(tick)


For configuration checklist for the OOTB Remedy AR System install configurations, see  Configuration checklist for Remedy Platform Open link .

For more information about compatibility with BMC and third-party products, see  BMC solution and product availability and compatibility utility (SPAC) Open link .


Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Peter Ekendahl

    Comatibility matrix for ARS 20.02 says Open Java 13 (no mention of 11). What is correct?

    Mar 16, 2020 05:56
    1. Manash Baruah

      Hello Peter,

      BMC validates new OpenJDK versions for compatibility with existing and new versions of Remedy ITSM suite. The Remedy ITSM suite 20.02 supports both OpenJDK 13 and OpenJDK 11. 


      Thanks,

      Manash

      Mar 17, 2020 12:48
  2. P Reddy

    This is what is shown in matrix.. !! Can you please clarify on this if we can go ahead with open java 11 Java Platform OpenJDK 13 (Current GA Release) 64-Bit Java Platform Standard Edition 1.8.0 Update 45 64-Bit Java Platform Standard Edition 11.0.5 Oracle LTS 64-Bit

    Mar 16, 2020 05:58
    1. Manash Baruah

      Hi,

      Remedy ITSM suite 20.02 is compatible with both OpenJDK 11 and OpenJDK 13.

      Thanks,

      Manash

      Mar 17, 2020 01:06
      1. Vamshikrishna reddy Giri

        How about OpenJDK 17 now ?

        Mar 03, 2022 03:46
        1. Himanshu Raul

          Hi Vamshikrishna,

          Remedy ITSM Suite 20.02 is compatible with OpenJDK 13 (or higher). For more information, see  BMC solution and product availability and compatibility utility (SPAC) Open link .

          Regards,

          Himanshu

          Apr 11, 2022 04:44
  3. Rudolf Vorlicek

    Hello,

    Someone should really remove that Adobe Flash Player column in this table, because I've spent last hour making sure there is really no way that you need adobe flash player for Remedy after it's termination.

    Thanks, Rudolf

    Sep 14, 2021 11:45
    1. Himanshu Raul

      Hi Rudolf,

      Thank you for pointing out this issue with the content. We have updated the topic with your feedback.

      Regards,

      Himanshu

      Sep 14, 2021 12:04