Frequently Asked Questions about upgrading and migrating Infrastructure Management

This topic presents some of the Frequently Asked Questions (FAQ) about upgrading and migrating to TrueSight Infrastructure Management.

FAQs about upgrading the Infrastructure Management Server

This section presents some of the FAQs about upgrading the Infrastructure Management server.

 What are the supported versions that can be upgraded to BMC TrueSight Infrastructure Management Server 11.3.01?

The previous released versions of TrueSight Infrastructure Management with the latest service packs applied.

For more information, see the following links:


 A BMC TrueSight Infrastructure Management Server has Integration Services and BMC PATROL Agents connected. Which component must be upgraded first?

 BMC recommends that the TrueSight Infrastructure Management server be upgraded first.

 The BMC TrueSight Infrastructure Management Server is upgraded but the PATROL Agents are not yet upgraded. Will existing KMs on the PATROL Agent work?

Yes, KMs compatible with existing PATROL Agent versions will continue to work.

 An Infrastructure Management server is upgraded to 11.3.01 and the Integration Service is also moved to 11.3.01. Will older versions of PATROL Agents work with the upgraded 11.3.01 Integration Service?
 Will the existing license file work after the Infrastructure Management Server is upgraded to 11.3.01?

Yes, the existing license file will work. Contact Customer Support for obtaining the latest license file.

 Is there an option to keep the data backup before upgrade and if there is a failure in the upgrade, is there an option to revert to the previous version of the BMC TrueSight Infrastructure Management Server?

Yes. BMC recommends that you back up your existing environment before the upgrade so that the environment can be restored in case of a failure.

 A BMC TrueSight Infrastructure Management Server running on an Oracle database is upgraded to 11.3.01. Does this work without making any changes to the database?

Yes, this will work without making any changes to database.

 In a multi-server deployment, which component must be upgraded first?

In a multi-server deployment, first upgrade the Child Servers followed by the Central Server.

FAQs about upgrading the Integration Service

This section presents some of the FAQs about upgrading the Integration Service.

 Can I route the upgraded PATROL Agent to a freshly installed 11.3.01 Integration Service?

Yes. Install a fresh 11.3.01 Integration Service, start upgrading each PATROL Agent, and move it to new Integration Service.

 Can I install a new 11.3.01 Integration Service on the same computer on which an older Integration Service exists?

Yes, multiple Integration Services are supported. You can install a fresh 11.3.01 Integration Service on the same computer and move the upgraded PATROL Agents to this Integration Service.

 Can I move the upgraded PATROL Agent to a new 11.3.01 Integration Service installed on a remote computer?

Yes, you can install a new 11.3.01 Integration Service on a different computer and move the PATROL Agents to that Integration Service.

 An Infrastructure Management server is upgraded to 11.3.01. There are multiple Integration Services connected. Will the data collection work from all of the Integration Services, if only one of the Integration Services and the related PATROL Agent are upgraded?

Yes, data collection from the remaining Integration Service(s) continues.

 What are the supported Integration Service versions prior to 11.3.01?

Infrastructure Management 11.3.01 works with Integration Services 11.0.xx with the latest service pack applied.

 How can I reduce the down time for data collection when switching to the new Integration Services?

You can install 11.3.01 Integration Services side-by-side on the same host or another host, and then upgrade the PATROL Agents and directly connect them to the 11.3.01 Integration Services.

Was this page helpful? Yes No Submitting... Thank you

Comments