Installation and upgrade considerations for BMC Event Adapters

BMC Event Adapters is installed with the Integration Service. Before installing, upgrading, or uninstalling BMC Event Adapters, ensure that the target system meets the installation requirement in this topic.

BMC recommends that you do not install BMC Event Adapters on the computer that has BMC TrueSight Infrastructure Management Server installed.

  • Before installing BMC Event Adapters, ensure that the appropriate version of Perl is installed as described in System requirements and product compatibility for Infrastructure Management
  • On Linux and Solaris systems, you must install the P5NCI library for the SNMPv3 adapter to work. You do not need to install the library on Microsoft Windows systems.
  • For certain libraries in the SNMPv3 adapter to work, Perl 5.14 must be installed. If you are using the SNMPv3 adapter, ensure that Perl 5.14 is installed. On Linux and Solaris systems, the SNMPv3 adapter requires the P5NCI package installed on the system in which the SNMPv3 adapter is configured and the P5NCI package is supported in Perl 5.14. As a best practice, configure the SNMP v3 adapter on the remote cell (which is not a part of the BMC TrueSight Infrastructure Management Server) with preinstalled Perl 5.14 and the P5NCI package. By default, the BMC TrueSight Infrastructure Management Server contains Perl 5.16 and the P5NCI package is not available.
Was this page helpful? Yes No Submitting... Thank you

Comments