To view the latest 11.3.x version, see  PATROL Agent 11.3.02 Open link .

TLS communication error due to security level mismatch

PATROL Agent is unable to communicate with TrueSight Integration Service in TLS mode due to security level mismatch.

Probable cause: The TLS communication fails if the PATROL Agent and TrueSight Integration Service are at different security levels. TrueSight Integration Service communicates with the PATROL Agent at security level 2 and above.

Resolution: As a workaround, do the following steps: 

  1. If you have already configured the PATROL Agent in the TLS mode, ensure that you unset the TLS mode before changing its security level. 
  2. Stop the PATROL Agent.
  3. Navigate to the <ROOT_INSTALL_DIR>\common\security\config_v3.0 directory location and run the following command: 

    p7_change_security_level_x86-64.cmd -c AGENT_CON -l 4 -n BOTH -d Patrol3 -v _v3.0
  4. Restart the PATROL Agent.


Was this page helpful? Yes No Submitting... Thank you

Comments