Upgrading

You can upgrade to the latest version of the PATROL for Microsoft Windows Servers suite by running the installation programs from the command line or from a wizard. To maximize uptime, you can also upgrade by migrating from the earlier versions of the component products to the current version. Depending on the products installed in your implementation of the suite, you might also need to migrate data or configurations to the current version. 

FAQs about upgrading PATROL for Microsoft Windows Servers

For the existing and the upgraded Microsoft Windows Servers KM components, are there any new attributes? Which attributes have been removed from the KM?

No attributes have been removed in 5.0.00 version of the KM. The following new attributes were introduced in 5.0.00:

  • Virtual Bytes MB (PROCVirtualBytesMB)
  • UsrProcVirtualBytesMB

The PATROL for Microsoft Cluster Server has been redesigned to support multiple new features. The following monitor types have been introduced in the KM:

  PATROL for Microsoft Cluster Server monitor types

Monitored object Monitor Types Description

Top-level containers and configuration

Used to set up and configure the PATROL for Microsoft Cluster product.

Cluster Network

Monitors the network and network interface status of the cluster.

Cluster Nodes

Provides node status and monitors keyword matches within the cluster log file.

Cluster Roles

Represents a cluster role or a group instance. Provides information about role and failover status, free and total disk space, resource status and IP resource response time.

Cluster Shares

Discovers and monitors the file shares on a cluster.

Cluster Shared Volume

Monitors the cluster shared volumes.

 

For any existing and the upgraded Microsoft Windows Servers KM components, are there any Monitor Type, Monitor Name or Attribute name changes that would affect any given Global and Instance threshold or any Advanced Event Rules?

No. 

For any existing and the upgraded Microsoft Windows Servers KM components, are there any incompatibilities?

No. Consider the following scenarios before upgrade.

  • Combination 1: An old Infrastructure Policy pointing to a PATROL Agent with the new version of PATROL for Microsoft Windows Servers. For example, an Infrastructure Policy using old Microsoft Windows Servers KM pointing to a PATROL Agent with the new Microsoft Windows Servers KM?
    Supported. The old policy (for example 4.9.00 or 5.0.00 ) works with the latest version of the KM.

  • Combination 2: The latest version Infrastructure Policy pointing to a PATROL Agent with the old version of PATROL for Microsoft Windows Servers. For example, an Infrastructure Policy using new Microsoft Windows Servers KM pointing to a PATROL Agent with the old Microsoft Windows Servers KM?
    Not recommended. Although this combination works (for example, 5.0.00 policy works with 4.9.00 KM), BMC strongly discourages you to use this combination of the policy and the KM. 

Is upgrade supported from 1.9.20 to 2.0.00 of the PATROL for Microsoft Cluster Server KM?

No. Microsoft Cluster Server 2.0.00 has been newly designed to support remote monitoring of Clusters.

Microsoft Cluster Server 1.9.20 and 2.0.00 version can be used on the same PATROL Agent server, but you cannot upgrade from 1.9.20 to 2.0.00 version of the KMPolicies that are created by using earlier versions of the KM (1.9.20 and earlier) are not supported with 2.0.00 version of the KM.

Which ports are required by PATROL for Microsoft Cluster Server KM 2.0.00?

  • RPC port
  • WinRM HTTP 5985
  • WinRM HTTPS 5986
Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Cassie Derrick

    Please confirm that "Combination 1:" listed above should actually say "Supported. The old policy (5.0.00) works with the latest (5.1.00) version of the KM"?

    Apr 10, 2019 04:37
    1. Shweta Patil

      Thank you for your comment, Cassie. The 5.0.00 policy works with 5.1.00 version of the KM. Combination 1 is an example indicating that if a policy is created with the earlier version of the KM, it works with the latest version of the KM. We have updated the documentation. Please let us know for more information.

      Apr 12, 2019 04:10