System requirements

This section lists the minimum requirements and supported resources for the PATROL for MongoDB product.

ResourceMinimum requirementsComments
Operating system
  • Microsoft Windows Server 2016, x86_64
  • Microsoft Windows Server 2012 R2, 64-bit, x86
  • Microsoft Windows Server 2008 R2, 64-bit, x64


  • Red Hat Enterprise Linux 7.x, x86_64
  • Red Hat Enterprise Linux 6.x
Red Hat Enterprise Linux 7.x is supported up to version 7.6
MongoDB
  • 4.0
  • 3.6.x
  • 3.4.x
  • MongoDB 3.6.x is supported up to version 3.6.6.
  • MongoDB 3.4.x is supported up to version 3.4.16
Java Runtime Environment (JRE)

Supports any of the following Java versions:

  • Oracle Java 8
  • OpenJDK 8

Note: For the latest announcement on BMC’s Java Support policies for TrueSight monitoring solutions, see Java support for TrueSight monitoring solutions


PATROL Agent
  • 9.6.00
  • 10.0.00
  • 10.7.00
  • 11.0.00
  • 11.3.01

PATROL Installation Utility
  • 10.7.00
  • 11.0.00
  • 11.3.00

TrueSight console
  • TrueSight Infrastructure Management 10.5.00
  • TrueSight Infrastructure Management 10.7.00
  • TrueSight Infrastructure Management 11.0.00
  • TrueSight Infrastructure Management 11.3.01

Related topics

Installing

Solution and Product Availability and Compatibility (SPAC)

Note

BMC products are certified for use on supported operating system versions. BMC does not explicitly test for OS patches/updates that are released after a BMC product is released.

BMC products should work fine with minor updates to these supported operating systems. For assistance, please contact BMC Customer Support.

Was this page helpful? Yes No Submitting... Thank you

Comments