System requirements

Support for third-party products

To receive full support for a BMC product, you must have that product installed in a supported environment, as specified in the BMC product documentation. If a third-party vendor cancels support for one of its products (such as an operating system or subsystem), and that third-party product integrates or interacts with the BMC product you have licensed, you must upgrade to a supported version of that third-party product before BMC Customer Support can provide you with support for the affected BMC product. For further information, see BMC's product support policy.

This topic lists the minimum requirements and supported resources for the PATROL for Apache Kafka product. Before installing PATROL for Apache Kafka, verify that the target computer meets the installation requirements listed in the following table.

Note

To get complete compatibility information for PATROL for Apache Kafka, use the BMC Solution and Product Availability and Compatibility Utility on the Product Availability and Compatibility page.


ResourceRequirementsComments
Operating systems
  • Microsoft Windows 2008, R2, 64-bit
  • Microsoft Windows 2012, 64-bit
  • Microsoft Windows 2012 R2, 64-bit
  • Microsoft Windows 2016, 64-bit
  • Red Hat Enterprise Linux 7.x, 64-bit

Red Hat Enterprise Linux 7.x is supported up to version 7.3.

Monitored Apache Kafka versions

PATROL for Apache Kafka can monitor multiple versions of the Apache Kafka Broker and Zookeeper.

The following table lists the local installation version of the KM and Producer with the corresponding Broker and Zookeeper version that you can monitor.

Apache Kafka KM and the Producer
local installation version
Corresponding Broker and Zookeeper
version that can be monitored
kafka_2.11-0.10.2.0kafka_2.11-0.10.2.0
kafka_2.11-0.10.1.1kafka_2.11-0.10.1.1
kafka_2.11-0.10.1.1kafka_2.11-0.10.2.0
kafka_2.11-0.10.2.0kafka_2.11-0.10.1.1
kafka_2.11-0.10.0.0kafka_2.11-0.10.0.0
kafka_2.11-0.10.0.0kafka_2.11-0.10.2.0
kafka_2.11-0.10.2.0kafka_2.11-0.10.0.0
kafka_2.11-0.10.1.0kafka_2.11-0.10.1.0
kafka_2.11-0.10.1.0kafka_2.11-0.10.2.0
kafka_2.11-0.10.2.0kafka_2.11-0.10.1.0

Important: Apache Kafka KM and the Producer must use the same version of Apache Kafka for local installation.

BMC TrueSight Presentation Server
  • 10.7.00

  • 10.5.00

  • 10.1.00

  • 10.0.00

 
BMC PATROL products
  • PATROL Agent 9.6.00, 10.0.00, and 10.7.00
  • PATROL Installation Utility 10.5.00 and 10.7.00
 
Java Runtime Environment (JRE)

Supports any of the following Java versions:

  • Oracle Java 8
  • OpenJDK 8

Note: For the latest announcement on BMC’s Java Support policies for TrueSight monitoring solutions, see Java support for TrueSight monitoring solutions

 

Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Sharon Thompson

    Kafka version 1.1.0 is also tested and supported by the Kafka KM. Please add this to the list of supported Kafka versions.

    Jul 18, 2018 06:18