Troubleshooting Common Interface Server issues


Use the information in this topic to solve common issues in Common Interface Server.

To make sure that CIS receives and displays data, confirm the Java directory configuration.

Issue

Your CIS STDOUT log displays the following error message:

CEE3501S The module libjvm.so was not found.
From entry point JzosVM::initializeVMArgs() at compile unit offset +000 00094 at entry offset +00000094 at address 4310620C.

Probable cause 

The error message indicates that the Common Interface Serverenvironment is not correctly pointing to the Java 17 for one of the following reasons:

  • You applied the latest PTF and the IBM SDK Java 17 is not in the default /usr/lpp/java/J17.0_64 directory.
  • Your Common Interface Serveris pointing to the correct Java directory, but updates to the Java package changed the Java SDK library location in your mainframe.

Resolution

If you have not yet applied the latest PTF, apply the PTF and complete the configuration. When the job is finished, restart the Common Interface Server. 

If you still see the error, your Common Interface Serveris probably not in the default directory. Perform the following steps:

  1. Open the CISERVER started task and update the installation path for CIS.
  2. Use the absolute path (for example, JAVAHOME='/usr/lpp/java/J17.0_64') to the Java 17 directory in your environment. 
  3. Restart the CISERVER started task and make sure that it runs with return code 0.

 

Issue

The system or user abend (S878 R=00000014) occurred during the initialization of CIS.

Probable cause 

The parameter for Java Virtual Machine (JVM) heap size is set to a minimum value by default. 

Resolution

Increase the JVM heap size.

  1. To increase the JVM heap size, edit the following default parameter values in the CISERVER member from the &INSTALLHLQ.BMCSAMP data set:
    IJO="-Xms256m -Xmx512m"
    1. Replace -Xms256m with Xms512m
    2. Replace -Xmx512m with -Xmx1048m
  2. Restart CIS.

If the problem persists, contact your system administrator. 

 

Issue

Common Interface Server fails to start

Probable cause 

Probable causes are as follows:

  • Incorrect CIS_HOME, Java Home, DSN on the mainframe, or Java version
  • The user that started the task has no permissions for CIS_HOME
  • The port is already in use
  • Incorrect security configurations
  • The system or user abend (S878 R=00000014) occurred during the initialization of CIS
  • The following message appears in the STDOUT log:

    CEE3501S

    The module libjvm.so was not found. From entry point JzosVM::initializeVMArgs() at compile unit offset +000 00094 at entry offset +00000094 at address 4310620C.

 

Resolution

Perform the following actions:

  • Verify that the security configurations are correct. 
  • If the working folder has changed, verify that the following files exist in CIS_HOME:
    • CommonInterfaceServer.jar
    • logback-spring.xml

 

Issue

The SSL connection is not working

Probable cause 

Incorrect parameter settings

Resolution

Verify and set the following parameters in the data set that relates to CIS:

  • CIS_SSL_ENABLE = true
  • CIS_PROTOCOL = https
  • CIS_KEYSTORE_TYPE = yourKeystoreType
  • CIS_KEYSTORE_ALIAS = yourKeystoreAlias
  • CIS_KEYSTORE_PASSWORD = yourPassword
  • CIS_KEYSTORE_NAME = yourKeystoreLocation

After setting the listed parameters, restart the server. If the issue persists, send the latest logs to BMC Support for further investigation.  

 

Issue

The SAF Keyring is not working

Probable cause 

Invalid parameter settings

Resolution

Verify and set the following parameters in the data set that relates to the CRA:

  • CIS_SSL_ENABLE = true
  • CIS_PROTOCOL = https
  • CIS_KEYSTORE_TYPE = <your keystore type>
  • CIS_KEYSTORE_ALIAS = <your keystore alias>
  • CIS_KEYSTORE_PASSWORD = <your password>
  • CIS_KEYSTORE_NAME = <your location of the keystore>

After setting the listed parameters, restart the server. If the issue persists, send the latest logs to BMC Support for further investigation.  

 

Issue

Common Interface Serverthrew an exception with the following message:

Not an absolute path: UIMDLL64         

Probable cause 

Unsupported Java version

Resolution

Upgrade to Java version 17.0.9 or later 

Issue

The following messages appear in the STDERR DD for the REFRGUID and REFRGUI steps (or similar for icm.md5 and IMSUIJAR):
cmp: gud.md5: EDC5129I No such file or directory.                              
oput 'MY.INSTALL.XXCONT(GUDUIJAR)' 'gud.jar' BINARY                         
rm: FSUM9195 cannot unlink entry "gud.md5": EDC5129I No such file or directory.

Probable cause 

This message is expected the first time the server starts because the files it is checking for don’t exist yet. The server should run normally.

Resolution

No action is needed. You can also see the STDOUT DD report in the GUI files being refreshed.

 

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