Troubleshooting Redhat Patch Catalog Update failures


Redhat Patch Catalog Update Job (CUJ) fails to update the patch catalog and displays an error message. This topic helps you investigate and troubleshoot the root cause of the failure.

Issue symptoms

A Redhat Patch Catalog Update job fails and the Catalog Update Job (CUJ) run log displays an error message.

Issue scope

The issue might occur with all Redhat CUJs or confined to a specific CUJ.

Diagnosing and reporting an issue

Task

Action

Steps

Reference

1

Understand the problem scope.


Do the following:

  • Check whether this issue affects all or specific Redhat Patch CUJs.
  • Check whether the issue occurs in all the Redhat Linux versions or specific versions.
  • Check the configured filters and child channels as shown in the attached image.
  • Check whether the issue is consistent or intermittent. Sometimes, rerunning the job resolves the issue.

RedHat Patch Catalog

image2020-9-17_12-53-20.png

Filter list

image2020-9-17_12-53-47.png

2

Identify the recent changes.


Check whether the affected Redhat CUJ was previously run successfully. If yes, verify whether any environment changes were made after the previous successful run, such as:

  • Updated filters defined in the patch catalog
  • HTTP Proxy changes
  • Certificate changes
  • TrueSight Server Automation upgrade to a new version


3

Identify and locate the logs.

  • Check the Redhat CUJ run log.
  • Check the logs for the Application Server where the failed CUJ was run.
  • Check the yum_metadata_generator.log from the Repository server.

To fetch the catalog update run log, right-click a failed run and select Export Log:

image2020-9-25_17-5-4.png

yum_metadata_generator.log location: //Reposerver/Repo_Dir/yum_metadata_generator.log

4

Review the logs to identify the issue.

Do the following:

  1. Review and analyze the gathered logs to troubleshoot the issue.
  2. Review the information in the "Resolutions for common issues" section to understand the common issues that can result in Redhat CUJ failures and how they can typically be resolved.
  3. If you are unable to identify and resolve the problem, create a BMC Support Case.


5

Creating a BMC Support Case

Provide the following information and log files when creating a case with BMC Customer Support:

  • Scope of the issue as identified in step 1
  • Any recent changes as identified in step 2
  • Logs gathered in step 3
  • The Application Server version and build
  • OS version of Redhat Repository Server


Resolutions for common issues

Symptom

Action

Reference

The CUJ Job Run log displays the following error message:

Error: PKIX path building failed: java.security.cert.CertPathBuilderException: Could not build a validated path.

Possible causes:

  • The Internet or proxy certificates have expired or changed
  • A known issue

Refer to the knowledge articles in the Reference section.

The CUJ Job Run log displays the following error:

Validation Error :- BLPAT1211 - Unable to find sqlite db required by yum.
Possible remediation steps :- Please check the yum_metadata_generator.log file generated in repo directory

Redhat certificates of the Repository server have either expired or revoked.

Refer to the Knowledge Articles in the Reference section.

See the following knowledge articles to generate and acquire new Redhat certificates:

The CUJ Job Run log displays the following error:

Catalog update fails with Error: Validation Error :- BLPAT1225 - Failed to run reposync on repo directory

yum_metadata_generator.log shows the following message:

Run at 28/08/2019 4:17:51 PM,Error,28/08/2019 4:18:04 PM,"Validation Error :- BLPAT1225 - Failed to run reposync on repo directory. Http error occured.

Error in yum_metadata_generator.log: No More mirrors to try

Possible causes:

  • Redhat certificates of the Repository server either expired or revoked.
  • Redhat CUJ fails on a specific RPM. This issue occurs when the reference softlink of rpm or the payload is missing from the repository location.
    Check for rpm presence in repository if its not showing either the softlink or the payload. Delete the existing entry and re-run the CUJ.

Refer to the Knowledge Article in the Reference section.

See the following knowledge articles to generate and acquire new Redhat certificates:

 

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