Important

   

This space contains documentation for TrueSight Server Automation 8.9.03 and the later service packs for 8.9. For earlier releases, see BMC Server Automation 8.9.

Version 8.9.04.003: Patch 3 for version 8.9.04

This topic contains information about the enhancements in TrueSight Server Automation 8.9.04.003 and provides instructions for downloading and installing the patch.

Enhancements

Support for new platform

TrueSight Server Automation now supports the Red Hat Enterprise Linux 8 operating system for patching and provisioning use cases (bare metal and physical provisioning only).

For the complete list of platforms supported by TrueSight Server Automation, see Supported platforms.


Addition of REST API endpoints

REST API support is added for the following resources: Deploy jobs, NSH Script jobs, NSH script, and BLPackage

You can use the APIs to perform the following operations:

  • Create, delete, and execute operations on NSH Script and Deploy jobs.
  • Retrieve events, results, and job runs on NSH Script and Deploy jobs.
  • Perform retrieve operation on the NSH script and BLPackage.
  • Perform group update and retrieve members.
  • Retrieve smart-group members by type.
  • Retrieve patch job analysis results for servers according to job ID and job run ID.

For the complete list of endpoints, see REST API endpoints supported in TrueSight Server Automation.


Addition of a new module for the offline database cleanup utility

A new BL Value module is added to the offline database cleanup utility to cleanup Oracle databases. For information about using the offline database cleanup utility, see Running the offline database cleanup utility.


Third-party software updates

The version of the SysInfo utility from MagniComp is updated to 10-H91 for Linux x64 operating systems.


Compliance content updates

The following templates are added in this version:

Template detailsInstructions for downloading and importing the template
Center for Internet Security (CIS) template for Oracle Linux 7 benchmark version 2.1.0 of December 27, 2017 with implementation for 223 rulesUpdating CIS for Oracle Linux 7 to newer benchmarks
Center for Internet Security (CIS) template for Oracle Linux 6 benchmark version 1.1.0 of December 27, 2017 with implementation for 223 rulesUpdating CIS for Oracle Linux 6 to newer benchmarks
Center for Internet Security (CIS) template for CentOS Linux 7 benchmark version 2.2.0 of December 27, 2017 with implementation for 223 rulesUpdating CIS for CentOS Linux 7 to newer benchmarks

For the complete list of available templates, see Compliance Content support and requirements.


Deployment of Microsoft Windows patches

You can now deploy the Microsoft Windows patches directly from the Depot by using one of the following options:

  • Add to Depot As BLPackage: Use this option to modify the BLPackage for performing some additional tasks after deploying a patch. For example, running some external commands.
  • Deploy: Use this option to deploy a patch directly.

In the earlier releases, these options were disabled.

For information about how to add BLPackages, see Adding a BLPackage to the Depot.

Enhanced Patch Analysis Job results

In Patch Analysis job results, the Reason column is now moved from the extreme right position to the left for better readability.

Applying the patch

The following table lists the build information for this release.

Oops, it seems that you need to place a table or a macro generating a table within the Table Filter macro.

The table is being loaded. Please wait for a bit ...


Release

Build number

EPD version number

Release date

Patch 3 for Service Pack 4 for version 8.9

8.9.04.292

8.9.04.003December 6, 2019
Patch 2 for Service Pack 4 for version 8.9

8.9.04.253

8.9.04.002September 18, 2019
Patch 1 for Service Pack 4 for version 8.9

8.9.04.227

8.9.04.001June 21, 2019
Service Pack 4 for version 8.9

8.9.04.200

8.9.04January 28, 2019
Patch 1 for version 8.9 Service Pack 3

8.9.03.647

8.9.03.001October 5, 2018
Service Pack 3 for version 8.9

8.9.03.162

8.9.03June 11, 2018

Downloading the patch

Patch 3 for version 8.9.04 includes full installers for all components. You can download the files for version 8.9.04.003 from BMC Electronic Product Distribution (EPD).

For full download instructions, see Downloading the installation files.

For a list of installation programs by operating systems, see Installation programs for TrueSight Server Automation.

Installing the patch as a new product installation

If you are installing this patch as a new product installation, do one of the following:

Upgrading to the patch

You can upgrade to this patch from the following versions of TrueSight Server Automation:

  • 8.9.04.002, 8.9.04.001, 8.9.04, 8.9.03.001, 8.9.03, 8.9.02, 8.9.01.001, 8.9.01, 8.9.00
  • 8.8.x
  • 8.7.x

Before you upgrade to this patch, do the following to avoid upgrade failure:

  • If you are using an SQL Server database, run the offline database cleanup utility. For more information, see Running the offline database cleanup utility.
  • If you are using an Oracle database, run the diagnostic and remediation script on the database. For more information, see this  KA .

To upgrade, do one of the following:

Using with TrueSight Smart Reporting for Server Automation 

The following versions of TrueSight Smart Reporting for Server Automation are supported with TrueSight Server Automation 8.9.x:

  • 19.01
  • 19.2
  • 19.2.01
  • 19.2.02
Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Duane Flett

    TSSR is STILL not working in my environment and therefore I still have BDSSA running in parallel; will TSSA Patch 3 work with BDSSA?

    Dec 06, 2019 05:44
    1. Justan Suss

      Same here. Is there anyone from BMC able to answer?

      Feb 10, 2020 03:09
      1. Oa Repsol

        same here

        Jul 30, 2020 02:19
        1. Vipin Sharma

          If you have applied "BSA89SP4_Enablement_Hotfix" on BDSSA environment then it will work with TSSA 89SP4 Patch3.

          Aug 02, 2020 09:56
  2. Tej Kadiyala

    Yes, we are also unable to get TSSR working with BSA 8.9.x. Asked to move from one version to other of TSSR and now it is 20.02.Don't see it listed if compatible with BSA 8.9.03.

    May 23, 2020 04:31
    1. Bipin Inamdar

      Tej, Please refer compatibility matrix for this. https://docs.bmc.com/docs/tssrsa192/compatibility-matrix-907292973.html

      Yes, BSA 8.9.03 is compatible with TSSR but if you want to use TSSR 20.02 then you need to install TSSA-DW 89SP4 Patch4. Please refer above matrix.

      May 25, 2020 11:35