This documentation supports the 2.0 version of Remedy with Smart IT.

To view the latest version, select the version from the Product version menu.

Upgrading Openfire chat

We encourage Remedy with Smart IT 2.0 customers to upgrade to Openfire version 4.0.2. 

Before you begin

  • Stop Openfire service.
  • Take a backup of the Openfire/conf and Openfire/plugins folders.

To upgrade Openfire chat to version 4.0.2

  1. Unzip Smart IT 2.0 installer and extract openfire folder located at
    (Windows) ...\Smart_IT_2.0.00.windows\windows\Smart_IT_MyIT\Disk1\files\0p3nf153wn.zip
    (Linux) ...\Smart_IT2.0.00.linux\linux\Smart_IT_MyIT\Disk1\files\0p3nf153lx.zip
  2. Copy the openfire folder from the extracted 2.0 version and replace the existing openfire folder. 
  3. Replace the openfire/conf folder with the backup folder.

  4. Reinstall Openfire plugins from the Admin console in the Plugins tab. 

    You can also copy the plugins installed previously from backup plugins folder if they are compatible with the Openfire version to which you want to upgrade by copying the plugins folder (except admin and search folder).

  5. Ensure Auth-plugin-full jar exists in the openfire/lib folder. 
  6. Restart Openfire service. 

Troubleshooting the Openfire upgrade

Oracle database users upgrading to Openfire version 4.0.2 cannot access the Admin console. To troubleshoot this issue, ensure the following requirements at met:

  • The openfire_oracle script located at ...\openfire-win-4.0.2\resources\database\upgrade\22 does not contain 'COLUMN'. Instead of 'ADD COLUMN', the script must include only ADD.
  • The latest version of Admin plugin available at ...\openfire\plugins\admin is used.
Was this page helpful? Yes No Submitting... Thank you

Comments