This documentation supports the 18.08 version of Remedy with Smart IT.

To view the latest version, select the version from the Product version menu.

Upgrading

Smart IT installer supports direct upgrade to Smart IT 18.08 from Smart IT version 1.5.01 and later. Remedy IT Service Management (ITSM) 18.05 with the latest patch is the minimum supported version for Smart IT 18.08.

Before you begin

The following table provides information about specific scenarios that you should consider prior to upgrading to Smart IT 18.08:

Scenario Consideration or action required
You are using Remedy with Smart IT 18.05 with the latest patch, and you have ITSM 18.05 with the latest patch. Now, you plan to upgrade to Smart IT 18.08 version.

Perform the following steps:

  1. Upgrade to Remedy AR System, Atrium Integrator, and CMDB 18.08:
    1. Upgrading BMC Remedy AR System
    2. Verify and complete the AR System upgrade
    3. Performing the BMC Remedy ITSM upgrade
    4. Completing the BMC Remedy ITSM upgrade

  2. Apply the latest deployment packages of ITSM, SRM, SLM 18.08:
    Installing ITSM
  3. Upgrade to Smart IT 18.08:
    1. (Pre-Upgrade)
      1. (Optional) Run the social data migration utility for Smart IT.
      2. Verify social data migration
    2. Upgrade to Smart IT 18.08.
      1. Verify the Smart IT upgrade.
    3. (Post-upgrade)
      1. (Optional) Run the migration utilities and perform the post-upgrade tasks.
    4. Upgrade Android and iOS mobile clients for Smart IT to 18.08.

You are using Remedy with Smart IT 2.0 and BMC Digital Workplace 3.5 with AR ITSM 9.1.x and you plan to upgrade both Smart IT and Digital Workplace to 18.08 version.

If you use Smart IT and BMC Digital Workplace both, always upgrade BMC Digital Workplace first.

The Smart IT 18.08 installer provides you the option to upgrade only Smart IT.

The Smart IT 18.08 installer does not have an option to upgrade BMC Digital Workplace.

Perform the following steps:

  1. Upgrade to BMC Digital Workplace 18.08:
    1. Installing the ITSM integration patch .
    2. Upgrading to BMC Digital Workplace 18.08 .
    3. (Optional) Run the social data migration utility for BMC Digital Workplace.

  2. Upgrade to Remedy AR System, Atrium Integrator, and CMDB 18.08:
    1. Upgrading BMC Remedy AR System
    2. Verify and complete the AR System upgrade
    3. Performing the BMC Remedy ITSM upgrade
    4. Completing the BMC Remedy ITSM upgrade

  3. Upgrade ITSM, SRM, SLM to 18.05:
    Installing ITSM .
  4. Apply the latest deployment packages of ITSM, SRM, SLM 18.08:
    Installing ITSM
  5. Upgrade to Smart IT 18.08:
    1. (Pre-Upgrade)
      1. (Optional) Run the social data migration utility for Smart IT.
      2. Verify social data migration
    2. Upgrade to Smart IT 18.08.
      1. Verify the Smart IT upgrade.
    3. (Post-upgrade)
      1. (Optional) Run the migration utilities and perform the post-upgrade tasks.
    4. Upgrade Android and iOS mobile clients for Smart IT to 18.08.

You are using Remedy with Smart IT 2.0 and BMC Digital Workplace 3.5 and you plan to upgrade only Smart IT because you do not use BMC Digital Workplace

BMC Digital Workplace will no longer be available for use.

  1. Upgrade to Remedy AR System, Atrium Integrator, and CMDB 18.08:
    1. Upgrading BMC Remedy AR System
    2. Verify and complete the AR System upgrade
    3. Performing the BMC Remedy ITSM upgrade
    4. Completing the BMC Remedy ITSM upgrade

  2. Upgrade ITSM, SRM, SLM to 18.05:
    Installing ITSM .
  3. Apply the latest deployment packages of ITSM, SRM, SLM 18.08:
    Installing ITSM .
  4. Upgrade to Smart IT 18.08:
    1. (Pre-Upgrade)
      1. (Optional) Run the social data migration utility for Smart IT.
      2. Verify social data migration
    2. Upgrade to Smart IT 18.08.
      1. Verify the Smart IT upgrade.
    3. (Post-upgrade)
      1. (Optional) Run the migration utilities and perform the post-upgrade tasks.
    4. Upgrade Android and iOS mobile clients for Smart IT to 18.08.
You are using Remedy with Smart IT 2.0 and BMC Digital Workplace 18.02 and you plan to upgrade both Smart IT 18.08 and BMC Digital Workplace 18.08 in two different servers. 

The Smart IT 18.08 installer provides you the option to upgrade only Smart IT.

The Smart IT 18.08 installer does not have an option to upgrade BMC Digital Workplace.

Perform the following steps:

  1. Upgrade to BMC Digital Workplace 18.08 and point to new Digital Workplace Database:
    1. Installing the ITSM integration patch .
    2. Upgrading to BMC Digital Workplace 18.08 .
    3. (Optional) Run the social data migration utility for BMC Digital Workplace.
  2. On the new server (Server 2), run a fresh install of Digital Workplace 18.08 and select Add to existing cluster.
  3. Upgrade ITSM, SRM, SLM to 18.05:
    Installing ITSM .
  4. Apply the latest deployment packages of ITSM, SRM, SLM 18.08:
    Installing ITSM .
  5. Upgrade to Smart IT 18.08:
      1. (Pre-Upgrade)
        1. (Optional) Run the social data migration utility for Smart IT.
        2. Verify social data migration
      2. Upgrade to Smart IT 18.08.
        1. Verify the Smart IT upgrade.
      3. (Post-upgrade)
        1. (Optional) Run the migration utilities and perform the post-upgrade tasks.
      4. Upgrade Android and iOS mobile clients for Smart IT to 18.08.
  6. Remove the dwp.xml file from the server 1 from the following path: tomcat/conf/Catalina/localhost

    Here, you have separate Smart IT 18.08 on the Server 1 and BMC Digital Workplace 1808 on the Server 2.


Refer to the following image to know the components that require the deployment package:



Upgrade sequence

Use the following graphic to make decisions about the upgrade and to understand the upgrade sequence:

Note

If you are upgrading from Smart IT 18.05 to Smart IT 18.08, you don't need to run the Social data migration utility while upgrading.


Upgrade best practices

  • BMC recommends to upgrade to the latest patch of Smart IT to get the best performance.
  • Use a separate database schema for Smart IT and BMC Digital Workplace.
  • Install Smart IT and Digital Workplace on separate Apache Tomcat servers.
  • Run all the upgrade utilities during the production cut-over activity.

Upgrade process

Smart IT upgrade comprises the following stages:

Before you begin

Task Action Additional information
1 Upgrade BMC Digital Workplace to version 18.08.

If you are using both Remedy with Smart IT and BMC Digital Workplace, you must upgrade BMC Digital Workplace to version 18.08. For instructions, see Upgrading BMC Digital Workplace in the Digital Workplace online documentation.

2 Install BMC Remedy ITSM version 18.05 and apply the latest deployment package of 18.08

Before you upgrade Smart IT, you must install BMC Remedy IT Service Management (ITSM) version 18.05 and apply the latest deployment package of 18.08. For instructions, see Installing BMC Remedy ITSM in the Remedy ITSM online documentation.

Stage 1: Prepare to upgrade Smart IT 

Task Action Additional information
1

Review the system requirements:

  • Compatibility matrix
  • Remedy On-Premises solution architecture
Make sure that you meet the system requirements for this release. For more information, see System requirements for Smart IT.
2 Review the known and corrected issues.
3 Download the Smart IT installation files. Find how to obtain the files that you need for installation from the BMC Electronic Product Distribution (EPD) site.
4 BMC has conducted an analysis of various performance test results and provided performance benchmarking methodology and environment. Recommendations based on the test results.
5 Complete the upgrade worksheets. Before installing the products, gather information about the parameters that the installer requires for each product. The planning spreadsheet provided in this section helps you gather these parameter values.

This information helps you avoid installation errors, when you run the installation.

6 Take a backup of Remedy AR server database and Smart IT database.  As a precaution in the event of an upgrade failure, back up both the BMC Remedy with Smart IT database and the BMC Remedy AR Server database.
7

Upgrade database


Optionally, due to the separation of BMC Digital Workplace and Smart IT products, during the Smart IT upgrade, you need to create new DB schemas/users. The new DB schemas/users will contain only Smart IT data. For more information, see Create databases.

The Smart IT installer will create the new DB schemas/users automatically. However, if you have database access restrictions and cannot allow the Smart IT installer to create schemas/users, you can create pre-existing schemas/users.

8 Migrate your social data.

If you are upgrading from any version earlier than 18.05, you need to migrate your social data as starting from 18.05, MongoDB is no longer used as the database to store your social data.

If you need to retain the old social timeline data, migrate your social data from MongoDB to the AR System. This migration ensures that the data is displayed seamlessly on the Smart IT dashboard after the upgrade.

9 Upgrade to 64-bit Java Runtime Environment (JRE) 8. Upgrade to JRE 8 on all the servers where Smart IT is installed. For information about downloading JRE 8, see http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html in the Oracle documentation.
10 Upgrade to Remedy Single Sign-On.

Smart IT does not support Atrium Single Sign-On (ASSO). If you are upgrading from an older version of Smart IT where you have ASSO, you need to remove ASSO integration or upgrade to Remedy Single Sign-On to upgrade Smart IT successfully. For more information, see the following topics:

Note: BMC recommends to upgrade the RSSO webagents when Smart IT is upgraded.

  Stage 2: Upgrade Smart IT

Task Action Additional information
1 Resolve issues indicated by the installer, if any.

Ensure that all the following pre-installation checks run by the installer are successful before proceeding with the installation:

  • Disk space
  • JAVA runtime version
  • Database version
  • Directory permissions
  • Smart IT installed version
  • Components operation status

The installation will not proceed if the pre-installation check detects inconsistencies in the required components.

3

Perform the Smart IT upgrade.

Do not use Xming to install the Smart IT server, because it might not perform reliably during installation. Instead, use VNC, MobaXterm, or any other client.
4 Verify the Smart IT server installation. Verify whether the upgrade is successful.

Stage 3: Review Smart IT configurations 

After you upgrade, review the following configurations to make your system more robust, secure, and efficient.

Task Action Additional information
1 Configuring SSL for the Tomcat server

To provide communication security among applications, configure SSL for the Apache Tomcat server. If you enabled SSL as part of the installation , SSL is already configured.

2

The integration of Remedy Single Sign-On with Smart IT.

Remedy Single Sign-On authentication applies to both the universal client and to mobile applications. When a user logs in to a mobile device, the user is prompted to enter the hostname and port. If the server has SSO enabled, the mobile client opens a browser to the SSO login page. The SSO server sets the SSO cookies after authentication on to the device browser. When the user relaunches the application, if the cookies are not expired, the mobile client displays the application. If the cookies are expired, the user is shown the login page again for authentication.

3 Smart IT permissions To give users access to Smart IT, assign them the required user permissions.
4 Login ID requirements for service requests in Smart IT

If your environment uses BMC Service Request Management, ensure that the People records for non-support staff include a login ID. Service requests cannot be submitted for a customer who has a People record with no login ID. Service requests cannot be submitted, because the Smart Recorder uses the login ID to show available  service request templates for that person .

5 Enabling full text search Full text search (FTS) is an optional feature that you can install with the Remedy AR System server. To use FTS with Smart IT, you must install Remedy Knowledge Management, even if you do not plan to create knowledge articles. To use the complete FTS capability, you must configure and enable the FTS feature.
6 Enabling SSL for Openfire chat server Complete the procedure to enable a secure sockets layer (SSL) for the Openfire chat server that runs with Remedy with Smart IT (Smart IT).
7 Configuring security options for Smart IT Limit the types of files that users can attach to Smart IT records. Update the content security policy to allow users to attach images from external sources to knowledge articles. If you have Openfire chat installed, edit the  openfire/conf/cross-domain-policy.xml  file to only allow access to data from a specific domain (or domains).
8 Configuring the reconciliation method for assets The Sandbox Job Calls setting, was added to the AST:AppSettings form in Smart IT 1.5. This setting controls how reconciliation calls (requests) are processed for assets.

 Stage 4: Deploy Smart IT to users

Task Action Additional information
1 (Optional) Perform the post-upgrade tasks. NA
2 IT users access Smart IT Apple iOS and Google Android mobile clients, as well as through the universal client. The universal client provides access through a web browser.
3 Rebranding Smart IT on the Universal Client Optionally, modify the CSS as per the design of Smart IT 18.08, if you have done the rebranding for the UX console before upgrading Smart IT.

Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Andreas Mitterdorfer

    Please can you add a section for upgrade from DWP 18.02?

    18.08 DWP installer reports "install version should not be lower than 18.05" when you have DWP 18.02 installed and want to upgrade.

    (Sep 14 2018 02:40:05.459 PM +0200),WARNING,com.bmc.install.product.projectgalileo.ProjectGalileoUpgradeValidationTask, LOG EVENT {Description=[Installed version should be not lower than 18.05.00],Detail=[18.02.00]} (Sep 14 2018 02:40:05.462 PM +0200),CONFIG,com.bmc.install.task.InstallationPropertiesHelper, LOG EVENT {Description=[SET PROPERTY VALIDATION_ERROR_RESULT],Detail=[INSTALLED_VERSION_LOWER_THAN_3_2]} (Sep 14 2018 02:40:05.462 PM +0200),INFO,com.bmc.install.product.projectgalileo.ProjectGalileoUpgradeValidationTask, LOG EVENT {Description=[Validation error],Detail=[Installed version should be not lower than 18.05.00.001]} (Sep 14 2018 02:40:05.462 PM +0200),CONFIG,com.bmc.install.task.InstallationPropertiesHelper,

    Sep 17, 2018 05:26
    1. Nilay Agambagis

      Hello Andreas,

      Thanks for your comment.

      Please check DWP documentation for DWP upgrade. If you use Smart IT and BMC Digital Workplace both, always upgrade BMC Digital Workplace first. Please check the Before you begin section in this topic for the required links to the DWP upgrade topic.

      Regards,

      Nilay Agambagis


      Sep 17, 2018 05:38