Note

 

This documentation supports the 20.15.02 version of BMC Remedyforce.

To view the latest or an earlier version, select the version from the Product version menu.

Importing data from BMC Atrium CMDB

You can import data and relationships from BMC Atrium Configuration Management Database (BMC Atrium CMDB) into BMC Remedyforce CMDB 2.0 by using Atrium Integrator 8.1 with customized Pentaho packages. These packages are available on the BMC Communities website. Different packages (saved in different folders) are provided for different CI types.

The following topics are provided:

Before you begin

Before importing data from BMC Atrium CMDB, you must meet the following requirements:

  • Download the Pentaho Data Integration tool.
  • Register at the BMC Communities website.
  • Download the Pentaho packages to import BMC Atrium CMDB data from the BMC Communities website. The Pentaho packages on the BMC Communities website are customized to be used in Atrium Integrator.

Note

You can use these Pentaho packages if you are using CMDB 2.0. For more information about CMDB, see BMC Remedyforce CMDB architecture.

  • Create a folder, Log Files, at the root level of the drive on which the AR System server is installed. For example, if you have installed the AR System server on the C: drive, create a C:\Log Files folder.

For more information about these procedures, see Prerequisites for importing data to BMC Remedyforce.

KJB and KTR files for importing data from BMC Atrium CMDB

A KTR file contains a single transformation. The KTR files that are provided for importing data from BMC Atrium CMDB contain the following steps:
A KJB file (job file) contains a series of transformations. The KJB file that is provided for importing data from BMC Atrium CMDB contains the following steps:

  • Start
  • AtriumToCMDB_<CI type>: This step contains transformations to import data from BMC Atrium CMDB.

List of KJB files for importing data from BMC Atrium CMDB

BMC Remedyforce provides Pentaho packages for importing different CI types from BMC Atrium CMDB. Each package contains a folder with a KJB file (job file) and the related KTR file. The following table lists the folder name for each CI type and the corresponding BMC Atrium CMDB class from which the job imports CIs to the BMC Remedyforce CMDB.

To import configuration items from BMC Atrium CMDB by using Pentaho packages

Before importing configuration items from BMC Atrium CMDB, perform all of the actions in Before you begin.

  1. Download the Pentaho package from the BMC Communities page. Click https://communities.bmc.com/docs/DOC-28437 and save the files to your computer.

    Note

    You can use these Pentaho packages if you are using CMDB 2.0. For more information about CMDB, see BMC Remedyforce CMDB architecture.

  2. Log on to BMC Remedy AR System and access the Atrium Integrator Console.
  3. To launch the Atrium Integrator Spoon, click .
  4. To create a new folder in Atrium Integrator to store your KTR and KJB files, perform the following actions:
    1. Go to Tools > Repository > Explore.
    2. Right-click the window, and select New Folder.
    3. Enter a name for the folder in which you want to save the KTR and KJB files that you have downloaded from the BMC Communities website, and click OK.
      For example, create a folder called Remedyforce.
  5. To save the KTR and KJB files in the folder, perform the following steps for each file:
    1. Click File > Open URL and browse to the folder in which you have saved the job files that you downloaded from BMC Communities.
    2. Open the KJB and KTR files for the required CI type, such as computer system.
    3. Click File > Save As.
    4. In the Directory field, click .
    5. Click OK.
  6. In the KJB file, double-click the AtriumtoCMDB_<CI type> step.
    For example, double-click the AtriumtoCMDB_ComputerSystem step.
  7. In the Job entry details for this transformation window, in the Specify by name and directory option, click , and select the KTR for the opened KJB file from the folder that you have created..
    For example, Remedyforce > AtriumToCMDB_ComputerSystem.ktr.
  8. Click File > Open, and open the required KTR file.
  9. To enter the information required to access the AR System from the KTR file, perform the following steps:
    1. In the KTR file, double-click ARInput.
    2. In the Connection field, click Edit.
    3. In the Settings section, enter the AR System server access details.
    4. (Optional) To test the connection with the server, click Test.
    5. Click OK.
  10. To enter the information required to access the SQL server that BMC Atrium CMDB uses, perform the following steps:
    1. Double-click Table Source.
    2. In the Connection field, click Edit.
    3. In the Database Connection window, if you are using another database type, in the Connection Type list, select the required connection type.
      Based on the database type that you are using, the query written in the Table Source step might change. In the step, the Oracle database query is also provided in a commented form. To use the Oracle query, remove the comment marks from the query and comment the MS SQL query.
    4. In the Settings section, enter the logon information of the SQL server that the BMC Atrium CMDB database uses.
    5. (Optional) To test the connection with the database, click Test.
    6. Click OK.
  11. To enter the information required to access your Salesforce organization, perform the following steps:
    1. Double-click Salesforce Input[CMDB_Class].
    2. In the Connection section, enter the Salesforce organization access details.
    3. (Optional) To test the connection, click Test connection.
    4. Click OK.
    5. Double-click Salesforce Upsert.
    6. In the Connection section, enter the same Salesforce organization access details.
    7. (Optional) To test the connection, click Test connection.
    8. Click OK.
  12. To save the KTR and KJB files, click .
  13. Navigate back to the Atrium Integrator Console.
  14. Select the job that you have set up, and click .
    While the data is being imported, the following log files are generated:
  • Job-level logs: Create in the Atrium Integrator Console.
  • Success, process, and error logs: Created as CSV files in the Log Files folder that you created in Before you begin. The failure log is created only if an error occurs in inserting a record in BMC Remedyforce. The delta_value log stores the time stamp of the last time you imported data. Rejected logs are also created if records with blank unique identifier values exist.

To import relationships from BMC Atrium CMDB by using Pentaho packages

Before importing relationships from BMC Atrium CMDB, perform all of the actions in Before you begin and import all the CIs from BMC Atrium CMDB. Also, create a folder, Log Files, at the root level of the drive on which the AR System server is installed. For example, if you have installed the AR System server on the C: drive, create a C:\Log Files folder.

  1. Log on to BMC Atrium Action Request System and access Atrium Integrator Console.
  2. To launch the Atrium Integrator Spoon, click .
  3. To save the KTR and KJB files in the folder on Atrium Integrator, perform the following steps for each file:
    1. Click File > Open URL and browse to the folder in which you have saved the job files that you downloaded from BMC Communities.
    2. Open the AtriumtoCMDB_BaseRelationship.kjb and AtriumtoCMDB_BaseRelationship.ktr files.
    3. Click File > Save As.
    4. In the Directory field, click .
    5. Click OK.
  4. In the KJB file, double-click the AtriumtoCMDB_BaseRelationship step.
  5. In the Job entry details for this transformation window, in the Specify by name and directory option, click , and select the AtriumtoCMDB_BaseRelationship.ktr from the folder where you have saved the KTR file.
  6. Click File > Open, and open the AtriumtoCMDB_BaseRelationship.ktr file.
  7. To enter the information required to access the BMC Remedy AR System from the KTR file, perform the following actions:
    1. In the KTR file, double-click ARInput.
    2. In the Connection field, click Edit.
    3. In the Settings section, enter the BMC Remedy AR System access details.
    4. (Optional) To test the connection with the server, click Test.
    5. Click OK.
  8. To enter the information required to access the SQL server used by BMC Remedy AR System, perform the following steps:
    1. Double-click Table Source.
    2. In the Connection field, click Edit.
    3. In the Database Connection window, in the Connection Type list, select MS SQL Server.
      If you are using another database type, select the required connection type and enter details in the Settings section.
    4. In the Settings section, enter the SQL server access details.
    5. (Optional) To test the connection with the database, click Test.
    6. Click OK.
  9. To enter the information required to access your Salesforce organization, perform the following actions:
    1. Double-click Salesforce Upsert.
    2. In the Connection section, enter the Salesforce organization access details.
    3. (Optional) To test the connection, click Test connection.
    4. Click OK.

      Note

      To enable creating relationships in BMC Remedyforce, do not change the mapping of the UniqueCIRelationshipID_c, UniqueDestinationCIIDc, and UniqueSourceCIID_c fields.

  10. If you have created custom relationships in the database used by BMC Atrium CMDB, perform the following actions:
    1. In Salesforce, navigate to Setup > Create > Objects.
    2. In the Label column, click Base Relationship.
    3. In the Custom Fields & Relationship s section, click Type.
    4. On the Base Relationship Custom Field Type page, in the Picklist Values section, click New.
    5. Enter the name of the BMC Atrium CMDB custom relationship, and click Save.
    6. Repeat step d and step e for all custom relationships that you are importing.
    7. Navigate to the Atrium Integrator Spoon.
    8. In the AtriumtoCMDB_BaseRelationship.ktr file, double-click the Read Response Variable step.
    9. Copy and paste the last "else if" statement.
      For example, else if(endsWith(ClassIdUpper,"BMC_SETTINGOF")){TypeScript="Setting Of";}
    10. Replace the first class string with the class ID of the custom relationship and the second text string with the value that you have added in the Type field, and save the step.
      For example, you are importing the mobile custom relationship type from BMC Atrium CMDB and in the Type field, you have added the Atrium Mobile value. In the Read Response Variable step, replace the text strings with the following text:
      else if(endsWith(ClassIdUpper,"MOBILE")){TypeScript="Atrium Mobile";}
      Ensure that the first text string is in uppercase.
      In this statement, ClassIdUpper is the name of the custom relationship in BMC Atrium CMDB, and TypeScript is the value that you have entered in the Type field.
    11. Repeat step i and step j for all custom relationships that you are importing.
  11. To save the KTR and KJB files, click .
  12. Navigate back to the Atrium Integrator Console.
  13. Select the job that you have set up, and click .
    While the data is being imported, the following log files are populated:
  • Job-level logs: Created in the Atrium Integrator Console.
  • Success, process, and error logs: Created as CSV files in the Log Files folder that you created in Before you begin. The error log is created only if an error occurs in inserting a record in BMC Remedyforce. The delta_value log stores the time stamp of the last time you imported data. Rejected logs are also created if records with blank unique identifier values exist.

Scheduling import jobs from the Atrium Integrator Console

Go to the Atrium Integrator Console to schedule jobs to import data from BMC Atrium CMDB. To schedule the import jobs, save the combined job KJB files in the Atrium Integrator folder in which you saved the KJB and KTR files for CIs and relationships, and provide the information required to access the BMC Remedy AR System, SQL database used by BMC Remedy AR System, and your Salesforce organization in the KJB and KTR files for all of the CIs. For more information, see To import configuration items from BMC Atrium CMDB by using Pentaho packages and To import relationships from BMC Atrium CMDB by using Pentaho packages.

Schedule the jobs (the combined job KJB files) in the following sequence:

  • AtriumToCMDBComputerSystem&Hardware
  • AtriumToCMDBComputerSystem&SoftwareServer
  • AtriumtoCMDB_BaseRelationship

Related topics

Overview of how is data imported in BMC Remedyforce

Importing data to custom attributes

Troubleshooting issues with importing data

Was this page helpful? Yes No Submitting... Thank you

Comments