Supported middleware monitoring technologies for performance and availability


The MainView Middleware Monitor product monitors only product versions supported by the manufacturer, unless specifically noted. For instance, if you experience problems using an unsupported version of WebSphere MQ, BMC requires that you upgrade to an IBM-supported version and duplicate the problem before contacting BMC Support.

If you are looking for the supported platforms for transaction monitoring, see Supported application transaction tracing technologies for transaction monitoring.

The following table lists the supported technology/platforms combinations. Platforms are listed across, technologies are listed down. A + symbol indicates a supported technology on that platform.

Platform
Monitored technology and version

AIX 6.1, 7.1, 7.2

HP-UX 11 Itanium

i5/OSa V7R1, V7R2, V7R3, V7R4

Linux (IBM-supported x86)

Linuxa (IBM-supported zSeries)

Solaris 10, 11 SPARCf

Solaris 10, 11 x86 (64-bit)f

TPF PUT 17b – 21

Windows 2016, 2019

z/OSa 2.1, 2.2, 2.3, 2.4

BMC MainView for WebSphere MQ 5.2

MainView for MQ 5.3, 5.4 c

+

+

+

+

d

IBM DataPower Firmware 6.0.2, 7.1.0, 7.2.0, 7.5.x, 7.6.x, 2018.4.1.x

+

+

IBM HTTP Server 8.5, 9.0

+

+

+

+

Oracle WebLogic 11, 12++
+
+

+

TIBCO EMS 8.0, 8.1, 8.2, 8.3, 8.4, 8.5

+

+

+

+

IBM WebSphere Application Server (qpwasmon) 8.5, 9.0

+

e

+

+

+

+

e

IBM Integration Bus (IIB) 10.0

+

+

+

+

+

+

+

+

IBM App Connect Enterprise (ACE) 11.0 +

+



+

IBM WebSphere MQ 5.1

+

IBM MQ 9.0

+

+

+

+

+

+

+

+

+

IBM MQ 9.1+
+++++ ++
Apache ActiveMQ 5.15.x


+



+
    1. Requires Java 1.7 or later for Java Extensions and the MVMM Configuration Agent (bmmtm_agent).
    2. Requires APAR PJ29430.
    3. MainView for MQ requires the most current RSU level.
    4. Monitoring BMC MainView for MQ on z/OS is supported by a remote monitoring extension. Contact BMC Support for details.
    5. Monitoring WebSphere Application Server on z/OS is supported by a remote monitoring extension. Contact BMC Support for details.
    6. These OS platforms are deprecated. The Solaris JREs available for distribution in MVMM bootstrap agent packages use an Oracle Java 8 JRE. BMC will not be providing updates for those JREs going forward. 

      For future updates on Solaris SPARC or X86 you must either provide your own Oracle JRE or use a JRE provided by one of the technologies being monitored. 

      As such, the Solaris SPARC and x86 platforms are being deprecated for possible removal in a future release. If you are using either of these platforms contact BMC Support so we can determine when and if either of these platforms should be removed in a future release.

Was this page helpful? Yes No Submitting... Thank you

Comments