Space announcements

   

This space provides the same content as before, but the organization of the home page has changed. The content is now organized based on logical branches instead of legacy book titles. We hope that the new structure will help you quickly find the content that you need.

Adding an execute SQL or DDL step to a work ID

This procedure explains how to add an execute SQL or execute DDL step to an existing work ID.

For more information about executing SQL, see Running SQL.

Before you begin

Ensure that you understand the concepts presented in the following sections:

To add an execute SQL/DDL step to a work ID

  1. Open the work ID that you want to edit and access the Step Type panel.

    For more information, see Creating and accessing a work ID.

  2. Select Execute SQL and press Enter.

    Log Master displays the EXEC SQL Options Menu.

  3. (optional) Enter values for the application plan that
    Log Master uses to execute your SQL file:
    1. Select Specify EXEC SQL Options.
    2. Enter the optional values.
    3. Press F3 to return to the EXEC SQL Options Menu panel.
  4. Select Specify SQL Dataset.

    Log Master displays the Execute SQL/DDL Dataset Name Entry panel (see following figure).

     WORKID ========================= Work ID Maintenance =========================
     C .---------------------------------------. _________________ Scroll ===> HALF
       | ============= Step Type ============= |                         SSID: DB2R
      .----------------------------------------------------------------------------.
      | =================== Execute SQL/DDL Dataset Name Entry ==================  |
      |                                                                            |
      | Current Dataset . . .                                                      |
      |                                                                            |
      | Proposed Dataset. . .                                                      |
      |                                                                            |
      | Options . . .                                                              |
      |   _  1. Search for an SQL Dataset                                          |
      |      2. Specify an SQL Dataset                                             |
      |      3. Search for an DDL Dataset                                          |
      |      4. Specify an DDL Dataset . . .                                       |
      |    ________________________________________________________________        |
      '----------------------------------------------------------------------------'
  5. Select one of the options, depending on whether you know the name of the data set that you want to use:
    • If you know the name of the SQL or DDL data set that you want to use:

      1. Type either 2 or 4 in the Options field.

      2. On the line below the options, type the name of the data set or a wildcard pattern and press Enter.

        In the Proposed Dataset field,

        Log Master displays the data set name that you entered.

    • To search for an SQL or DDL data set:

      1. Type 1 or 4 in the Options field and press Enter.

      2. On the search criteria panel, type your search criteria and press Enter.

        Log Master displays a list of the data sets that meet your specifications.

      3. Beside the data set that you want to use, type S and press F3.

        Log Master displays the Execute SQL Dataset Name Entry panel with the data set that you selected in the Proposed SQL Dataset field.

  6. Press F3 to return to the Work ID File Menu and save the work ID.


Was this page helpful? Yes No Submitting... Thank you

Comments