This documentation supports the 18.05 version of Remedy IT Service Management Suite.

To view the latest version, select the version from the Product version menu.

Troubleshooting issues for BMC Remedy Smart Reporting

Was this page helpful? Yes No Submitting... Thank you

Comments

  1. David k Hill

    Thanks for including the steps to deal with the Submit (400) error in Tomcat 8+. That solved several problems we were having.

    May 24, 2019 09:36
    1. Vrishali namdev Galinde

      Hi David,
      Thank you for your feedback!

      Regards,

      Vrishali


      May 27, 2019 11:38
  2. David k Hill

    It would be nice to know specifically which JAR files are responsible for making the web service calls to the Smart Reporting server and what version of Mid-Tier uses what version of those JAR files to communicate with which version of the Smart Reporting Server. It's all a black box operation from our perspective.

    May 24, 2019 09:38
    1. Vrishali namdev Galinde

      Hi David,

      Thank you for your comment. I shall take this up with the R&D team and get back to you soon.

      Thanks & Regards,

      Vrishali

      May 27, 2019 11:39
      1. David k Hill

        Any update?

        Jul 05, 2019 12:14
        1. Vrishali namdev Galinde

          Hello David,

          For Mid-Tier to Smart Reporting, web-services 7.1 and 7.3 jar files are responsible. The file is located in both smart reporting and midtier install locations:


          Smart Reporting :

          C:\Program Files\BMC Software\ARSystem\SmartReporting\appserver\webapps\AdminConsole\WEB-INF\lib


          Mid-Tier :

          ARSystem\midtier\WEB-INF\lib

           Ideally, the web service jar file should be of same version on both smart reporting and mid-tier. However, this dependency does not exist in SP3 and above versions.

           Please refer https://communities.bmc.com/docs/DOC-62913 for more information.


          Thanks & Regards,

          Vrishali

          Aug 01, 2019 12:56
  3. David k Hill

    For the section "The level value is changed to debug" The log4j_pluginsvr.xml file contains several appender configurations. Can you please be more specific on exactly which appender that should be set to "debug".

    Would it be this one:

    Jul 05, 2019 12:32
    1. Vrishali namdev Galinde

      Hello David,

      You need to change the log level value for the SmartReportingLog appender.


      Regards,

      Vrishali

      Aug 01, 2019 05:45
  4. David k Hill

    Also, it would nice to know specifically which server in the server group configuration as to which server logging should be enabled. (All or plugin host.).

    Jul 05, 2019 12:36
    1. Vrishali namdev Galinde

      Hello David,

      Thank you for your comments. I am following up with the R&D team for all the above queries. I shall keep you posted as soon as I get any update on the same.


      Thanks & Regards,

      Vrishali

      Jul 18, 2019 12:00
    1. Vrishali namdev Galinde

      Hello David,

      The user sync runs on the Admin server or primary AR Server. So you need to enable the logging on the Admin or primary server.


      Regards,

      Vrishali

      Aug 01, 2019 05:48