Page tree

Unsupported content

 

This version of the documentation is no longer supported. However, the documentation is available for your convenience. You will not be able to leave comments.

Before deciding whether to migrate to a new Infrastructure Management 10.0 instance or to upgrade the existing BMC TrueSight Infrastructure Management Server(s), it is best to understand interoperability related to the solution components. The following sections cover interoperability between solution components with differing versions (9.5, 9.6, and 10.0). Do not attempt to deviate from or circumvent the limitations outlined here.

BMC TrueSight Infrastructure Management Server

The following are interoperability points regarding the BMC TrueSight Infrastructure Management Server:

  • You can use the BMC TrueSight Infrastructure Management Server installer to upgrade earlier versions. See Upgrading.
  • The BMC TrueSight Infrastructure Management Server 10.0 can simultaneously interoperate with Integration Service versions 10.0, 9.6, and 9.5, assuming that the latest service packs have been applied to the 9.5 Integration Services.
  • The 10.0 BMC TrueSight Infrastructure Management Server and Administration Console must be manually configured to support 9.6 and 9.5 Integration Services for a fresh 10.0 installation. This assumes that earlier Integration Services with a 10.0 BMC TrueSight Infrastructure Management Server is required for some period of time. If this is not required, you do not need to adjust this configuration.
  • When the BMC TrueSight Infrastructure Management Server, 9.5 and 9.6, or later is upgraded, the same versions of the Integration Service nodes are readily supported. Architecture specific to versions 9.6 and 9.5 is not included in this topic. For information about Infrastructure Management 10.0 architecture, see Deployment use cases and best practices.
  • Mixed versions of BMC TrueSight Infrastructure Management Servers are discouraged in a single environment. However, events from different versions can be propagated between versions. Integration with Central Monitoring Administration of Presentation Server and integration across service models in Infrastructure Management 10.0 with older Infrastructure Management versions for extended periods of time must be avoided.

Integration with BMC Remedy IT Service Management

The following are interoperability points regarding Infrastructure Management, BMC Remedy IT Service Management, and BMC Integration with Remedy Service Desk.

  • The integration between Infrastructure Management 10.0 and BMC Remedy IT Service Management includes an upgrade to the Service Impact Management (SIM) extensions in Remedy and components associated with automated ticket generation in BMC Integration with Remedy Service Desk.
  • Infrastructure Management 10.0 is compatible with BMC Remedy IT Service Management version 8.1 SP1 and SP2. Other versions are not supported, including BMC Remedy IT Service Management 8.0.
  • Consider the following regarding the Intelligent Ticket integration with BMC Remedy IT Service Management: 
    • There are two major parts to the Intelligent Ticketing 2.0 patch: Infrastructure Management updates and BMC Remedy IT Service Management updates
    • The Intelligent Ticketing 2.0 patch updates are included in Infrastructure Management 10.0 and BMC Remedy IT Service Management 8.1 SP1 and SP2 . Therefore, Infrastructure Management 10.0 and BMC Remedy IT Service Management 8.1 SP1 and SP2 do not require the Intelligent Ticketing 2.0 patch.
    • Any version of BMC Remedy IT Service Management earlier than 8.1 SP1 requires the Intelligent Ticketing patch updates to be applied to BMC Remedy IT Service Management.

    • Intelligent Ticketing 2.0 is supported with BMC Remedy IT Service Management versions 8.1. Other versions are not supported, including BMC Remedy IT Service Management version 8.0.

Integration Services

The following are interoperability points regarding Integration Services:

Note

The Integration Service process in 10.0 replaces the earlier Integration Service processes, including the earlier Infrastructure Management remote agents and the pproxy process.

  • The Integration Service version 10.0 cannot host earlier versions of PATROL Adapters. No PATROL Adapters are associated with 10.0 Integration Services.
  • A server can host both earlier and the new Integration Service processes if you set the ports so that they do not conflict and you provide proper resources (CPU, memory, disk, and so on).
  • Due to architectural improvements, the 10.0 Integration Service is not backward compatible with older PATROL Agents. The Integration Service 10.0 can only communicate with PATROL Agent versions 9.5.00 or later. Earlier versions of agents are denied access if a connection is attempted. A corresponding event is generated if this happens.
  • Integration Services 9.5, and later versions can operate with BMC TrueSight Infrastructure Management Servers 10.0. Earlier versions of Integration Services are not supported with a fresh installation of BMC TrueSight Infrastructure Management Server without custom configuration. Limit the use of Integration Services 9.6 and 9.5 in a 10.0 environment to upgrade and migration scenarios where no other method is feasible.
  • Integration Services earlier than 9.5 and 9.6 cannot interoperate with Infrastructure Management 10.0.
  • You can use an Integration Service earlier than 10.0 in the following scenarios:

    • Monitoring AS/400
    • Monitoring HP OpenVMS
    • Monitoring legacy operating systems or using KMs that are not supported by the PATROL Agent 9.5. For example, monitoring Windows 2000 managed nodes.

Event management cells

The following are interoperability points regarding event management cells:

  • Infrastructure Management 10.0 can process events that are propagated from previous versions of event management cells. In some cases, this can require configurations to support customizations and/or specific event content and processing.

PATROL Agents

The following are interoperability points regarding PATROL Agents:

  • To leverage all of the new functionality in Infrastructure Management 10.0, PATROL Agent 9.5.x or later must be used.
  • PATROL Agent 9.6 cannot be installed on the same managed node that contains earlier versions of the PATROL Agent.
  • PATROL Agent 9.6 can be connected to Integration Service versions 9.0.00 SP3, 9.5 or later if the PATROL Agent is “polled” for data using the p3Adapter profile in the pproxy process configured for the Integration Service. Streaming under this scenario is not allowed. Do not use this method in a Infrastructure Management 10.0 environment. Use this capability only in a 9.0 environment in which agents are already polled by p3Adapter. Although you can stream in a 9.5 environment, it must be avoided.
  • PATROL Agent 9.5 is denied connection to earlier Integration Services if you attempt to stream with the SA adapter configuration.

Related topics

Supported integrations with other BMC products

Benefits and risks to upgrades and migrations

Migration versus upgrade decision chart

Prerequisites to planning an upgrade or migration

Upgrade process overview

Migration process overview