Page tree

Skip to end of metadata
Go to start of metadata

This section details how to migrate your existing KB to the latest standard 9.6.00 KB.

Note

You must migrate and merge your KB only if it contains any customizations.

Overview of KB migration

Your existing KB might contain customizations, such as class definitions and rules that are unique to your environment, so you must migrate and merge these customizations with the new 9.5.00 standard KB. After you merge your KB, it contains the following components:

  • Definitions from your existing KB
  • New definitions from the latest KB

You must do this merger before you start the server upgrade because the upgrade process requires the KB to be current. You must migrate every KB in your BMC ProactiveNet implementation. The migration process is a combination of several configuration steps.

Supported KB migration paths

The following table lists the supported KB migration paths:

Existing version

Upgrade path

Reference

BMC ProactiveNet versions 9.0.xx or 9.5.xx

You can directly migrate to standard 9.6.00 KB from 9.0.xx or 9.5.xx KB.

See Executing the KB Migration Wizard (Microsoft Windows) and Executing the KB Migration Wizard (Solaris or Linux).

BMC ProactiveNet version 8.6.02.xx

To migrate to standard 9.6.00 KB, perform the following steps:

  1. Migrate to standard 9.0 or 9.5 KB
  2. Migrate to standard 9.6.00 KB

For information about migrating from standard 8.6.02 or 9.0 KB to 9.5.00 KB, see Executing the KB Migration Wizard (Microsoft Windows) and Executing the KB Migration Wizard (Solaris or Linux).

For information about migrating from standard 9.0 or 9.5 KB to 9.6.00 KB, see Executing the KB Migration Wizard (Microsoft Windows) and Executing the KB Migration Wizard (Solaris or Linux).

BMC ProactiveNet version 8.5.xx

To migrate to standard 9.6.00 KB, perform the following steps:

  1. Migrate to standard 9.0 KB
  2. Migrate to standard 9.6.00 KB

For information about migrating from standard 8.5 KB to 9.0 KB, see the BMC Support site to access the April 2012 version of the BMC ProactiveNet Upgrade Guide supporting BMC ProactiveNet 9.0.00.

For information about migrating from standard 9.0 or 9.5 KB to 9.6.00 KB, see Executing the KB Migration Wizard (Microsoft Windows) and Executing the KB Migration Wizard (Solaris or Linux).

BMC ProactiveNet versions 8.0

To migrate to standard 9.6.00 KB, perform the following steps:

  1. Migrate to standard 8.6.02 KB
  2. Migrate to standard 9.5.00 KB
  3. Migrate to standard 9.6.00 KB

For information about migrating from standard 8.0 KB to 8.6.02 KB, see the BMC Support site to access the July 2011 version of the BMC ProactiveNet Upgrade Guide supporting BMC ProactiveNet 8.6.02.

For information about migrating from standard 8.6.02 to 9.5.00 KB, see Executing the KB Migration Wizard (Microsoft Windows)  and  Executing the KB Migration Wizard (Solaris or Linux).

For information about migrating from standard 9.5 KB to 9.6.00 KB, see Executing the KB Migration Wizard (Microsoft Windows) and Executing the KB Migration Wizard (Solaris or Linux).

BMC ProactiveNet versions 7.7

To migrate to standard 9.6.00 KB, perform the following steps:

  1. Migrate to standard 8.5 KB
  2. Migrate to standard 9.0 KB
  3. Migrate to standard 9.6.00 KB

For information about migrating to standard 8.5 KB, see the BMC Support site to access the October 2010 version of the BMC ProactiveNet Upgrade Guide supporting BMC ProactiveNet 8.5.

For information about migrating from standard 8.5 KB to 9.0 KB, see the BMC Support site to access the April 2012 version of the BMC ProactiveNet Upgrade Guide supporting BMC ProactiveNet 9.0.00.

For information about migrating from standard 9.5 KB to 9.6.00 KB, see Executing the KB Migration Wizard (Microsoft Windows) and Executing the KB Migration Wizard (Solaris or Linux).

BMC Event and Impact Management versions 7.1, 7.2, 7.3.xx, or 7.4

To migrate to standard 9.6.00 KB, perform the following steps:

  1. Migrate to standard 8.6.02 KB
  2. Migrate to standard 9.5.00 KB
  3. Migrate to standard 9.6.00 KB.

For information about migrating from standard 8.0 KB to 8.6.02 KB, see the BMC Support site to access the July 2011 version of the BMC ProactiveNet Upgrade Guide supporting BMC ProactiveNet 8.6.02.

For information about migrating from standard 8.6.02 to 9.5.00 KB, see Executing the KB Migration Wizard (Microsoft Windows)  and  Executing the KB Migration Wizard (Solaris or Linux).

For information about migrating from standard 9.5 KB to 9.6.00 KB, see Executing the KB Migration Wizard (Microsoft Windows) and Executing the KB Migration Wizard (Solaris or Linux).

Prerequisite for KB migration

Before you migrate a KB, you must install a BMC ProactiveNet Integration Service 9.6 on a separate computer in your monitoring environment because the KB Migration Wizard requires a latest Integration Service. For information about installing a BMC ProactiveNet Integration Service, see Installing the BMC ProactiveNet Integration Service on Microsoft Windows and Installing BMC ProactiveNet Integration Service and BMC ProactiveNet Remote Cell on Linux, IBM AIX, or Solaris.

Note

BMC ProactiveNet does not support customized severity or status definitions. You must remove all customized severity and status definitions from the existing KB before attempting the migration.

2 Comments

  1.  

  2.