Page tree
Skip to end of metadata
Go to start of metadata

If you are running earlier versions of BMC ProactiveNet or BMC TrueSight Infrastructure Management than the two most recent versions, you must either migrate to the latest version or perform one or more upgrades before you can directly upgrade to the latest version of Infrastructure Management

Best Practice

Instead of performing a phased upgrade that can cause considerable downtime, consider a side-by-side approach where you install a new version of the product and then failover to it at the end of the implementation process. See Benefits and risks to upgrades and migrations.

 Upgrading from BMC ProactiveNet 9.5.xx, 9.6.xx, or Infrastructure Management 9.6.xx, 10.0

You cannot directly upgrade to BMC TrueSight Infrastructure Management Server 10.7 from BMC ProactiveNet 9.5.xx, 9.6.xx, or Infrastructure Management 9.6.xx, 10.0. To upgrade to BMC TrueSight Infrastructure Management Server 10.7, perform the following steps:

  1. Upgrade to BMC Infrastructure Management Server 10.0.500 or 10.5.xx with the latest patch or Service Pack.

    To upgrade BMC ProactiveNet 9.5.xx, 9.6.xx, or Infrastructure Management 9.6.xx, 10.0 to version 10.5, see one of the following options:

  2. Upgrade to BMC TrueSight Infrastructure Management version 10.7.

    To upgrade Infrastructure Management 10.0.500, 10.0.500.xx, 10.5, or 10.5.xx, see one of the following options:

Best practices when upgrading from ProactiveNet 9.5, 9.6, or Infrastructure Management 9.6, 10.0

Upgrade process overview for Infrastructure Management

 Upgrading from BMC ProactiveNet Server 9.0.xx

You cannot directly upgrade to BMC TrueSight Infrastructure Management Server 10.7 from BMC ProactiveNet Server 9.0.xx. To upgrade to BMC TrueSight Infrastructure Management Server 10.7, perform the following steps:

  1. Upgrade to BMC ProactiveNet version 9.5 or 9.6, or BMC Infrastructure Management Server 9.6, 10.0 with the latest patch or Service Pack.

    To upgrade BMC ProactiveNet 9.0.xx or 9.5.xx to version 9.6, see one of the following options:

  2. Upgrade to BMC Infrastructure Management Server 10.0.500 or 10.5.xx with the latest patch or Service Pack.

    To upgrade BMC ProactiveNet 9.5.xx, 9.6.xx, or Infrastructure Management 9.6.xx, 10.0 to version 10.5, see one of the following options:

  3. Upgrade to BMC TrueSight Infrastructure Management version 10.7.

    To upgrade Infrastructure Management 10.0.500, 10.0.500.xx, 10.5, or 10.5.xx, see one of the following options:

Best practices when upgrading from ProactiveNet 9.0

The following information is specific to upgrading from ProactiveNet 9.0:

  • ProactiveNet 9.0 must first be upgraded at least to 9.0 SP1 before upgrading to Infrastructure Management 10.7.
 Upgrading from BMC ProactiveNet Server 8.6.02.xx

You cannot directly upgrade to BMC TrueSight Infrastructure Management Server 10.7 from BMC ProactiveNet Server 8.6.02. To upgrade to BMC TrueSight Infrastructure Management Server 10.7, perform the following steps:

Note

  • ProactiveNet 8.6.02 must first be upgraded to at least SP3 before upgrading to Infrastructure Management 10.7.
  • ProactiveNet 8.6.02 does not include Central Monitoring Administration. Therefore, all policies created in Infrastructure Management 10.7 are new and there is no concern for policy upgrades or related conflicts.

 

  1. Upgrade to BMC ProactiveNet version 9.5 with the latest patch or Service Pack.

    To upgrade BMC ProactiveNet 8.6.02.xx or 9.0.xx to version 9.5, see one of the following options:

  2. Upgrade to BMC Infrastructure Management Server 10.0.xx or 10.5.xx with the latest patch or Service Pack.

    To upgrade BMC ProactiveNet 9.5.xx, 9.6.xx, or Infrastructure Management 9.6.xx, 10.0 to version 10.5, see one of the following options:

  3. Upgrade to BMC TrueSight Infrastructure Management version 10.7.

    To upgrade Infrastructure Management 10.0.500, 10.0.500.xx, 10.5, or 10.5.xx, see one of the following options:

 Upgrading from BMC ProactiveNet Server 8.5.xx

You cannot directly upgrade to BMC TrueSight Infrastructure Management Server 10.7 from BMC ProactiveNet Server 8.5.xx. To upgrade to BMC TrueSight Infrastructure Management Server 10.7, perform the following steps:

Note

The significant change between ProactiveNet 8.5 and Infrastructure Management 10.7 results in variances in functionality, capability, and behaviors that are likely to cause confusion for users and perceived issues in version 10.7 that are actually related to data collected previous to the upgrade and previous to upgrading agents.

 

  1. Upgrade to BMC ProactiveNet version 9.0 with the latest patch or Service Pack.

    To upgrade from BMC ProactiveNet 8.5.xx to version 9.0, see the BMC Support site to access the April 2012 version of the BMC ProactiveNet Upgrade Guide supporting BMC ProactiveNet 9.0.
  2. Upgrade to BMC ProactiveNet version 9.5 or Infrastructure Management version 9.6.

    To upgrade BMC ProactiveNet 8.6.02.xx or 9.0.xx to version 9.5, see one of the following options:



    To upgrade BMC ProactiveNet 9.0.xx or 9.5.xx to version 9.6, see one of the following options:

  3. Upgrade to BMC Infrastructure Management Server 10.0.xx or 10.5.xx with the latest patch or Service Pack.

    To upgrade BMC ProactiveNet 9.5.xx, 9.6.xx, or Infrastructure Management 9.6.xx, 10.0 to version 10.5, see one of the following options:

  4. Upgrade to BMC TrueSight Infrastructure Management version 10.7.

    To upgrade Infrastructure Management 10.0.500, 10.0.500.xx, 10.5, or 10.5.xx, see one of the following options:

 Upgrading from BMC ProactiveNet Server 7.7 or 8.0
You cannot directly upgrade to Infrastructure Management Server 10.7 from BMC ProactiveNet Server 7.7 or 8.0. To upgrade to BMC TrueSight Infrastructure Management Server 10.7, perform the steps in Migration process overview for Infrastructure Management.

Related topics

Supported upgrade paths for Infrastructure Management

Preparing for the Infrastructure Management upgrade

Determining whether to upgrade or migrate from an earlier version