Maintenance outage for upgrade on Sunday, September 22

This site, docs.bmc.com, will be inaccessible for two hours starting at 9 AM CDT, Sunday, September 22, for a platform upgrade.

    Page tree
    Skip to end of metadata
    Go to start of metadata

    This topic provides information on BMC Event Adapters requirements on various platforms.

    BMC Event Adapter requirements for Microsoft Windows

    Component

    Requirement

    Platform

    Intel-compatible processor (32 bit and 64 bit)

    Supported operating systems

    • Microsoft Windows Server 2012
    • Microsoft Windows Server 2008 and 2008, R2 (32 bit and 64 bit)
    • Microsoft Windows Vista, SP1 (Impact Explorer and upgrades only)
    • Microsoft Windows XP Professional, SP2 (32 bit and 64 bit)
    • Microsoft Windows Server 2003, SP1 and SP2 (Standard and Enterprise Editions) (32 bit and 64 bit)

    BMC Event Adapter requirements for Solaris

    Component

    Requirement

    Platform

    SPARC

    Supported operating systems

    • Sun Solaris 11
    • Sun Solaris 10 (64 bit)
    • Sun Solaris 10 zones (64-bit)
    • Sun Solaris 9

    BMC Event Adapter requirements for Linux

    Component

    Requirement

    Platform

    Intel-compatible processor (32 bit and 64 bit)

    Supported operating systems

    • Red Hat Enterprise Linux Enterprise Server 5.5 (64 bit)
    • Red Hat Enterprise Linux Enterprise Server 6.2 (64 bit)
    • SUSE Linux Enterprise Server 11 SP2 and SP3

    BMC Event Adapter requirements for AIX and HP-UX

    Component

    Requirement

    Platform

    POWER

    Supported operating systems

    • AIX 6.1,7.1
    • HP-UX 11.23

    Perl requirements for BMC Event Adapter

    The Integration Service installation script installs and starts the BMC Event Adapter. However, the installation script does not install Perl, which is required by the BMC Impact Event Adapters. You must separately install Perl 5.14 or later (32 bit) before you install the BMC Event Adapter on the system in which the Integration Service is installed.

    To use the SNMP v3 adapter, you must install Perl 5.14 and the following additional Perl modules:

    Operating system

    Required Perl module

    Microsoft Windows

    • Win32 API

      Note

      The Win32 API is also required for 64 bit Microsoft Windows.

    Solaris
    Linux

    • P5NCI-0.31
    • Module-Build-0.3607
    • ExtUtils-CBuilder-0.2703
    • Test-Exception-0.29
    • Sub-Uplevel-0.22

    Note

    BMC products are certified for use on supported operating system versions. BMC does not explicitly test for OS patches/updates that are released after a BMC product is released.

    BMC products should work fine with minor updates to these supported operating systems. For assistance, please contact BMC Customer Support.

    2 Comments

    1. Please share all Compatible versions of Active Perl we can use. It should not be restricted to version 5.14. Kindly refer below link for details around versions available for Perl to download -

      http://downloads.activestate.com/ActivePerl/releases/

      1. Hi Anuparn,

        Can we use active perl verion 5.24.3 to configure SNMP V3 adapter?