Page tree
    Skip to end of metadata
    Go to start of metadata

    Before installing Atrium Single Sign-On, which is a prerequisite product for the Presentation Server, ensure that its target system meets the following requirements:

    Warning

    If you have configured the Atrium Single Sign-On to work with SAML V2.0 (authentication through federated single sign-on, the Atrium Single Sign-On integration will not work with TrueSight Presentation Server.

    Related topics

    Planning the Presentation Server deployment

    System requirements for Presentation Server

    Load balancer requirements and guidelines for Atrium Single Sign-On high availability

    Using LDAP (Active Directory) for authentication

    Supported external authentication

    LDAPv3, Active Directory

    BMC recommends Active Directory for external authentication and does not support any of the other external authentication options supported by Atrium Single Sign-On product.

    Sizing information

    ParameterSmall environmentMedium environmentLarge environment
    CPU2 CPU4 CPU4 CPU
    RAM4 GB4 GB8 GB
    Storage configuration100 GB100 GB100 GB

    Supported browsers

    See System requirements and compatibility.

    Supported web or application servers

    The Tomcat 6.x and later web/application server and servlet engine are supported on all operating systems and platforms supported by BMC as defined in the Supported hardware platforms and operating systems section.

    Firewalls

    The ports that you selected when you installed the BMC Atrium Single Sign-On server must be accessible from the clients that are authenticated through the server. Configure the firewalls to allow access to the HTTPS port used for authentication, as well as the LDAP and Apache MQ ports in the nodes of a cluster.

    Java support

    BMC Atrium Single Sign-On requires at least Java 6.0 or later.Supportedvendor is:

    Operating systemVendorMinimum recommended versions
    Windows, Solaris, Linux (Red Hat)Oracle

    Java SE 6 - 1.6.0_28 (32-bit or 64-bit)

    Java SE 7 - 1.7.0_17 (32-bit or 64-bit)

    Java SE 8 - 1.8.0_66 (32-bit or 64-bit)

    Note

    Oracle refers to Java 1.6 as “6.0”. For more details, see Java SE Naming and Versions.

    Entropy level requirements

    If you are installing BMC Atrium Single Sign-On on Red Hat Enterprise Linux computers, the entropy level on the server must be at least 3000. Otherwise, you might experience installation issues. If an installation or silent installation aborts suddenly, finishes veryquickly,or takes a long time to complete, the computer might be experiencing low entropy issues. To avoid these issues, perform the following tasks:

    • Verify the level of entropy in the entropy_avail file at the following location: cat /proc/sys/kernel/random/entropy_avail
    • If the level of entropy is less than 3000, run the following commands as root user or restart your computer. Running the command is the preferred option as it helps in maintaining the entropy level after installation. If your server has a low entropy level, you should configure your server to run the following commands while starting up your server.

      rngd
      yum install rng-tools
      echo 'EXTRAOPTIONS="-i -o /dev/random -r /dev/urandom -t 10 -W 2048"' >>/etc/sysconfig/rngd
      chkconfig rngd on
      service rngd restart

    You must also ensure that the "rngd" process is running.

    3 Comments

    1. What are the Supportet OS for the WebSSO? On this Page it is not clear?

    2. See System requirements and compatibility.
      This does not point to the Systems requirements of the WebSSO. That is confusing.
      1. Thanks your comment. We'll update this page with the missing information, but in the meantime, you can find the system requirements for Atrium Single Sign-On at the following location: System Requirements.