Troubleshooting AMI Manager

Use this topic to solve problems with AMI Manager. The following issues are listed:

Tomcat REST interface error

Issue

The following message is displayed in the user interface:

PDTAM0030E: Tomcat Rest interface not available

This could be caused by the following issues:

Tomcat is not running

SSL is not configured properly

Tomcat is not running

The following message is issued in the AMI Manager log:

ERROR
com.bmc.ami.controllers.AppController - PDTAM0059E: Error occurred when
connecting to Tomcat Rest Interface: I/O error on GET request for
"http://<server>:<port>": Connection refused: connect; nested exception is
java.net.ConnectException: Connection refused: connect

Probable cause

Tomcat is not running.

Resolution

Restart Tomcat.



SSL is not configured properly

One of the following messages is issued in the AMI Manager log:

ERROR
com.bmc.ami.controllers.AppController - PDTAM0059E: Error occurred when
connecting to Tomcat Rest Interface: I/O error on GET request for
"https://<server>:<port>": Unrecognized SSL message, plaintext connection?;
nested exception is javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?

or

ERROR
com.bmc.ami.controllers.AppController - PDTAM0059E: Error occurred when
connecting to Tomcat Rest Interface: I/O error on GET request for
"https://qac5:15546": sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target;
nested exception is javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Probable cause

AMI Manager is trying to connect using SSL, but SSL is not configured properly.

Resolution

Make sure SSL is configured properly. See Enabling TLS authentication between Tomcat and AMI Manager for more details.



Data preparation address space is incorrect or down

Issue

The following message is displayed in the user interface:

PDTAM0042E: Exception occurred : ["Error Occurred
processing train","Request failed: Unknown AMI ID:
<address_space_name> Name Token failure: BMC AMI "

The following message is issued in the AMI Manager log:

ERROR
com.bmc.ami.controllers.AppController - PDTAM0059E: Error occurred when
connecting to Tomcat Rest Interface: ["Error Occurred processing  train","Request failed: Unknown AMI
ID: <address_space_name> Name Token failure: BMC AMI "

Probable cause

The data preparation address space entered in the amipdt.properties file is incorrect or the address space is not available.

Resolution

Verify that the data preparation address space entered in the amipdt.properties file is correct and that the address space is running.



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