Unsupported content

 

This version of the documentation is no longer supported. However, the documentation is available for your convenience. You will not be able to leave comments. Click here to view the documentation for the current version.

Compatibility matrix

This page describes the platforms supported with this release of BMC MyIT. To configure and use with BMC Remedyforce, you must use BMC MyIT OnDemand. You cannot use the on-premise version of BMC MyIT.

To understand the compatibility matrix, refer to the following topics:

Review the Product Availability and Compatibility Matrix

Review the Product Availability and Compatibility for the latest information about platforms currently supported.

To access this information, you must log in with your BMC support login and password.

BMC MyIT requirements

Note

Some BMC Remedy with Smart IT (Smart IT) information is included here for your convenience. If you are planning to install Smart IT, see System requirements for Smart IT for a comprehensive description of supported configurations.

BMC MyIT Server Installation Requirements
ProductDetails/VersionPurpose
VM or physical machineSee Sizing and scalability considerations.Smart IT and BMC MyIT server

Windows Server

Linux Server

2008 R2, 2012, 2012 R2, 2014

Red Hat Enterprise 6

Smart IT and BMC MyIT server
Oracle JRE1.8 (64-bit)Smart IT and BMC MyIT server
Required Components

BMC Service Desk: Incident Management, Problem Management

BMC Knowledge Management 

BMC Atrium Core 

7.6.04 SP2, 8.x, 9.0, and 9.1

Submit Incident, Approval, Knowledge articles

BMC Service Request Management

BMC Service Level Management

BMC Change Management

BMC Asset Management

7.6.04 SP2, 8.x, 9.0, and 9.1

These component are optional for BMC MyIT.

BMC Atrium Single Sign On8.x and 9.0Authentication (if you do not use BMC Remedy AR System)
BMC Remedy Single Sign On

9.0.01 and 9.1

Authentication (if you do not use BMC Remedy AR System)

One of the following:

  • Microsoft SQL Server
  • Oracle  

At least 2 GB space for database

  • 2008, 2012
  • 11g and later
BMC MyIT database
Optional Components
MongoDB
  • 2.6.x
  • 3.0.x
  • MongoDB 3.2.x (recommended)

Social database

The BMC MyIT installer includes a bundled 3.2.1 MongoDB that you can install. However, if you wish to configure MongoDB for high availability, you must install MongoDB without using the BMC MyIT installer.

BMC TrueSight Operations Management8.6, 9.0, 10.0, and 10.1Monitoring service health

Microsoft Exchange Server

Exchange Online / Office 365

2010, 2013Reserving conference rooms
Microsoft Active Directory (LDAP)2008 R2Notifications
BMC AppZoneSaaSAppZone account to deploy applications
Client
Universal Client

Browser running on laptop/desktop:

  • Google Chrome browsers (Macintosh OS X, Microsoft Windows XP and later)
  • Internet Explorer 9 and above browsers (Microsoft Windows XP and later)
  • Mozilla Firefox browsers (Microsoft Windows XP and later)
  • Apple Safari (Macintosh OS X)

Browser-based application

Note

The Smart IT universal client is not supported on mobile browsers.  

BMC MyIT mobile client app

iOS 8 and iOS 9 (iPhone, iPad)

Android 4.2 and later (Android devices)

Native application
Administrator Console

Browser running on laptop/desktop:

  • Google Chrome browsers (Macintosh OS X, Microsoft Windows XP and later)
  • Mozilla Firefox browser (Macintosh OS X, Microsoft Windows XP and later)
  • Internet Explorer 9 and above browsers (Microsoft Windows XP and later)
Browser-based application

Mongo DB compatibility matrix

Application version

Mongo DB supportedMongo DB shipped Elasticsearch supported Elasticsearch shipped 

BMC MyIT 2.0

MongoDB 2.4.x

MongoDB 2.4.8

Elasticsearch 0.9.10

Not provided

BMC Remedy with Smart IT 1.0

BMC MyIT 2.1

MongoDB 2.4.x

MongoDB 2.4.8

Elasticsearch 0.9.10

Elasticsearch 0.9.10

BMC Remedy with Smart IT 1.0 SP1

BMC MyIT 2.2

MongoDB 2.4.xMongoDB 2.4.8Elasticsearch 0.9.10Elasticsearch 0.9.10

BMC Remedy with Smart IT 1.1

BMC MyIT 2.5

MongoDB 2.4.x

MongoDB 2.6.x (recommended)

MongoDB 2.6.8

(MongoDB 2.4.x) Elasticsearch 0.9.10

(MongoDB 2.6.x) Elasticsearch 1.4.2

Elasticsearch 1.4.2

BMC Remedy with Smart IT 1.2

BMC MyIT 2.6

MongoDB 2.4.x

MongoDB 2.6.x (recommended)

MongoDB 2.6.8

(MongoDB 2.4.x) Elasticsearch 0.9.10

(MongoDB 2.6.x) Elasticsearch 1.4.2

Elasticsearch 1.4.2

BMC Remedy with Smart IT 1.3 

BMC MyIT 3.0

MongoDB 2.6.x

MongoDB 3.0.x (recommended)

MongoDB 3.0.6

Elasticsearch 1.4.2Elasticsearch 1.4.2

BMC Remedy with Smart IT 1.4 

BMC MyIT 3.1

MongoDB 2.6.x

MongoDB 3.0.x

MongoDB 3.2.x (recommended)

MongoDB 3.2.1Elasticsearch 1.4.2Not provided

Compatibility exceptions

  • iOS:SmartIT cannot be installed on OS version 8.0.2. The OS version must be equal to or greater than then 8.1.
  • BMC Remedy IT Service Management version 9.0 requires version 11.2.0.3.0 - 64-bit Production Oracle database. BMC Remedy with Smart IT can be installed on earlier versions of BMC Remedy ITSM.  However, if BMC Remedy ITSM version prior to 9.0 uses an earlier version of the Oracle database, the BMC Knowledge Management feature is not supported on Smart IT-MyIT.
Was this page helpful? Yes No Submitting... Thank you

Comments