This documentation supports the 3.3 version of BMC Digital Workplace. To view the latest version, select the version from the Product version menu.

Compatibility matrix

This page describes the platforms supported with this release of BMC Digital Workplace. 

To get complete compatibility information for BMC Digital Workplace 3.3, use the  BMC SOLUTION AND PRODUCT AVAILABILITY AND COMPATIBILITY UTILITY (SPAC)

Note

To access the product compatibility information on the Customer Support website, you must have a Support ID.

To understand the compatibility matrix, refer to the following topics:

Note

Some Remedy with Smart IT (Smart IT) information is included here for your convenience. If you are planning to install Smart IT, see System requirements for Smart IT in the Smart IT online documentation, for a comprehensive description of supported configurations.

BMC Digital Workplace and Smart IT server installation requirements

Component Version and other details
VM or physical machine See Sizing and scalability considerations.

Windows Server

Linux Server

2008 R2, 2012, 2012 R2

Red Hat Enterprise 6 or later and CentOS 6 or later

Oracle Java Runtime Environment (JRE) 1.8 (64-bit)

BMC Digital Workplace Catalog server installation requirements

Component Version and other details
VM or physical machine See Sizing and scalability considerations.

Linux Server

BMC Digital Workplace Catalog can be installed only on Linux servers.

  • Red Hat Enterprise Linux 6.5 or later
  • CentOS 6.5 or later

Oracle Java Runtime Environment (JRE)

Version 1.8 (64-bit or 32-bit)

If Java is not installed on the application server, Oracle JRE 1.8 is installed with the application. If Java is installed on the server then specify the Java JRE folder location when you edit the required options file.

Note

Some BMC Digital Workplace Catalog features, such as the image processing library, require Oracle Java. OpenJDK does not support these features, and can be safely removed if it is not required by other applications.

Required components

Application or component Version and additional details Purpose

Either of the following database engines:

  • Microsoft SQL Server
  • Oracle

At least 2 GB space for database

  • 2008, 2012

    • For BMC Digital Workplace Catalog, the database must be installed on a Windows Server 2008 R2, 2012 R2, or 2014 R2.
    • Microsoft SQL Server on Linux has not been tested.

  • 11gR2 or later

    Note

    BMC Remedy ITSM version 9.0 requires version 11.2.0.3.0 - 64-bit Production Oracle database. BMC Digital Workplace and Smart IT can be installed with BMC Remedy ITSM 8.1 or later. However, if BMC Remedy ITSM uses an earlier version of the Oracle database, the BMC Knowledge Management feature is not supported in either Smart IT or BMC Digital Workplace.

    • For BMC Digital Workplace Catalog, use version 11.2.04 or later.
    • If using SID, Oracle restricts the SID to 8-characters or fewer, case-insensitive.
    • If using service name, set up an Oracle Real Application Cluster (RAC) to link multiple servers through the Single Client Access Name (SCAN) service.
      For more information, see the following resources on the Oracle website:

BMC Digital Workplace database

BMC Digital Workplace Catalog requires a separate data storage for system and tenant data.

BMC Remedy IT Service Management (ITSM)

BMC Service Request Management

8.1 or later

Approvals, knowledge articles

Enables the following functions through the BMC Remedy service connector:

  • Submit service requests, work orders
  • Submit incidents
  • Submit change requests
  • Direct entry, retrieval, and update of any BMC Remedy application form

BMC Remedy Single Sign On

or BMC Atrium Single Sign On

9.0.01 or later

8.x and 9.0

BMC Digital Workplace Catalog requires with BMC Remedy Single Sign On 9.1.03 or later; see Configuring BMC Remedy Single Sign-On integration for BMC Digital Workplace Catalog

Authentication (if you do not use BMC Remedy AR System)

Required for Configuration Management database service connector and enables additional integration in BMC Digital Workplace Catalog for imported service requests that are mapped to requestable offerings.

Required to enable authentication for BMC Digital Workplace end user requests for services in the BMC Digital Workplace Catalog.

MongoDB
  • 2.6.x
  • 3.0.x
  • MongoDB 3.2.x (recommended)

Social database

To configure MongoDB for high availability or to install on a separate server, you must install MongoDB. The BMC Digital Workplace and Smart IT installer includes a bundled MongoDB 3.2.1; if you do not specify the MongoDB server during installation, the installer installs this bundled MongoDB.

Optional components

Application or component Version and additional details Purpose
Microsoft Active Directory (LDAP) 2008 R2

Notifications Active Directory service connector

BMC HR Case Management

4.6 or later BMC Digital Workplace Catalog requires version 4.7 or later.

 HR solutions and knowledge articles. Submit HR cases.
BMC Cloud Lifecycle Management 4.5 and 4.6 Request and decommission virtual machines

The following optional components are applicable for Digital Workplace Advanced:

Application or component Version and additional details Purpose
BMC TrueSight Operations Management 8.6, 9.0, 10.0, and 10.1 Monitoring service health

Microsoft Exchange Server

Exchange Online / Office 365

2010, 2013 Reserving conference rooms
BMC Virtual Chat (formerly BMC Virtual Agent) 8.1.02 or later Live chat between self-service user and an IT agent
 


For Catalog, the database must be 2008 R2, 2012 R2, or 2014 R2.
Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Phindiwe Moshoele
    Hi I am looking for any info on compatability of Office 365 exchange with version 7.6.04...
    Jun 07, 2017 03:37
  2. Tony Chung

    Hi Phindiwe. BMC Digital Workplace requires Remedy 8.1 or later (BMC Digital Workplace Catalog supports version 8.1 SP2 or later). Microsoft Office 365 exchange has not been tested with BMC Digital Workplace for client operations. However, the BMC Digital Workplace Catalog connector requires Office 365. Speak to your account representative to discuss your specific requirements. Thanks!

    Jun 23, 2017 10:14