Node.js Limitation for Automation API CLI

March 26, 2024: BMC is alerting you to an issue in the version support for node.js that you install for Control-M Automation API Command Line Interface (CLI).

CTM-9797: Various API commands fail when the Control-M Automation API Command Line Interface (CLI) uses user-installed node.js version 20 or later.

Workaround: Until this issue is resolved, BMC recommends that you install node.js version 18 for your installations of Control-M Automation API CLI, as discussed in Installing the Control-M Automation API CLI

Note that the Control-M Automation API CLI that BMC provides for Control-M/Agent already has node.js version 18.

Was this page helpful? Yes No Submitting... Thank you

Comments