Software requirements

This topic was edited by a BMC Contributor and has not been approved.  More information.

Supported operating systems


Supported Remedy Single Sign-On Server and Presentation Server versions

TrueSight Presentation Server versions

11.3.01, 11.3.02, 11.3.03

Remedy Single Sign-On version

9.1.03 and later


Remedy SSO latest patches and hot fixes

  • If you have Remedy Single Sign-On installed, you must check and apply the relevant patches for a seamless integration with the TrueSight Presentation Server.
  • Before proceeding with the patch installation, if the TrueSight Presentation Server is running, stop the TrueSight Presentation Server and back up Remedy Single Sign-On.

Supported Presentation Server integrations

You can integrate Presentation Server with TrueSight Operations Management components and other BMC products. For more information, see the following topics:

  • Supported Presentation Server integrations with TrueSight Operations Management components
  • Supported Presentation Server integrations with other BMC products

Remedy Single Sign-On Server

See Remedy Single Sign-On system requirements.

Presentation Server

Support for third-party products

To receive full support for a BMC product, you must have such product installed in a supported environment, as specified in the BMC product documentation. If a third-party vendor cancels support for one of its products (such as an operating system or subsystem), and that third-party product integrates or interacts with the BMC product you have licensed, you must upgrade to a supported version of that third-party product before BMC Customer Support can provide you with support for the affected BMC product. For further information, see BMC's product support policy.

Microsoft Windows

Component

Requirement

User Rights

Administrative privileges

Supported versions of Microsoft Windows

Microsoft Windows 2019

  • Microsoft Windows 2019 Standard Edition (64-bit)
  • Microsoft Windows 2019 Datacenter Edition (64-bit)

Microsoft Windows 2016

  • Microsoft Windows 2016 Standard Edition (64-bit)
  • Microsoft Windows 2016 Datacenter Edition (64-bit)

Microsoft Windows 2012 

  • Microsoft Windows 2012 R2 Standard Edition (64-bit)  
  • Microsoft Windows 2012 R2 Datacenter Edition (64-bit)
  • Microsoft Windows 2012 Standard Edition (64-bit)  
  • Microsoft Windows 2012 Datacenter Edition (64-bit)  

Microsoft Windows 2008

  • Microsoft Windows 2008 R2 Standard Edition (64-bit)
  • Microsoft Windows 2008 R2 Datacenter Edition (64-bit)
  • Microsoft Windows 2008 R2 Enterprise Edition (64-bit)

Linux

Component

Requirement

User Rights

A non-root user who has modification permissions to specific directories and files.
A user with root privileges cannot install the TrueSight Presentation Server.

Note: Umask must be set to 022.

Supported versions of Linux

  • Red Hat Enterprise Linux 6.x and 7.x
  • SUSE Linux Enterprise Server 11.x, 12.x, and 15
  • Oracle Linux Server 6.x and 7.x

Notes

  • BMC products are certified for use on supported operating system versions. BMC does not explicitly test for OS patches/updates that are released after a BMC product is released.
  • BMC products should work fine with minor updates to these supported operating systems. For assistance, contact BMC Customer Support.

Red Hat subscription 

The product requires some additional libraries to be present on the system (see list below).

The preferred method to add any missing libraries is to use the yum command to fetch the necessary library packages from the RHN (Red Hat Network) repository via the Internet.  To use this method, a Red Hat subscription is needed. Register the system by clicking System > Administration > Red Hat Subscription Manager in the menu on the server itself.  After registering the system, you can use yum install to download and install the required libraries from the RHN.

X Windows 

If you are installing the TrueSight Presentation Server by using the graphical user interface, you must install X Windows.

On the Red Hat Enterprise Linux terminal, type yum grouplist and check that X Window System is listed.  If not, then run yum groupinstall 'X Window System' to install the necessary packages.   

Required libraries

Ensure that the following libraries are present to install the TrueSight Presentation Server.  To install the libraries, use the following commands.

Library

Command to install the library on RHEL

Command to install the library on SUSE

libXtst (32-bit)

libXtst (64-bit)

yum install libXtst.i686 libXtst.x86_64

    libXtst-1.0.1-3.1

    libX11-devel-1.0.3-11.el5

N/A

glibc (32-bit)

glibc (64-bit)

yum install glibc.i686 glibc.x86_64

    glibc-2.12.x86_64

    glibc-2.12-1.107.el6.i686

    glibc-devel-2.5-65

zypper install glibc-32bit glibc

libstdc++ (32-bit)

libstdc++ (64-bit)

yum install libstdc++.i686 libstdc++.x86_64

zypper install libstdc++-32bit libstdc++

compat-libstdc++-33 (32-bit)

compat-libstdc++-33 (64-bit)



yum install compat-libstdc++-33.i686 

    compat-libstdc++-33.x86_64

    compat-libstdc++-33-3.2.3-69.e16.i686 

zypper install libstdc++33-32bit libstdc++33 

compat-libstdc++-296 (32-bit)

Note: This is not required for RHEL 7.6.

yum install compat-libstdc++-296.i686

N/A

pam (32-bit)

pam (64-bit)

yum install pam.i686 pam.x86_64

    pam-1.1.1-13.e16.i686

zypper install pam-32bit pam

libgtk-x11-2 (32-bit)

yum install libgtk-x11-2.0.so.0

N/A

Application Server and ETL Engine Server

Computers or virtual machines that host the TrueSight Capacity Optimization Application Server and ETL Engine Server components must be running one of the following supported platforms:

Note

  • For Application Server, ETL Server, and Gateway Server components, only x86_64 architecture is supported for the operating systems.
  • To install a TrueSight Capacity Optimization component by using the wizard (GUI) on any Linux operating system, ensure that you install the Xvfb package.

Operating system

Version

Required libraries

Red Hat Enterprise Linux

6.7 to 6.9

perl-5.10.1, libXtst, open-sans-fonts.noarch
7.3 to 7.5perl-5.16.3, libXtst, liberation-sans-fonts

Oracle Linux

6.7 to 6.9

perl-5.10.1, libXtst
7.3 to 7.5 perl-5.16.3, libXtst

CentOS

6.7 to 6.9

perl-5.10.1, libXtst
7.3 to 7.5perl-5.16.3, libXtst

SUSE Linux Enterprise Server

11 SP3 to 11 SP4

perl-5.10.0, perl-libwww-perl
12 SP2 to 12 SP3 

Note

  • If you are installing the Application Server using the User Interface, ensure that an XServer is either installed locally on your workstation or installed on a remote machine to which you can export the display. If you are connecting to the client from a remote workstation by using a XServer server, ensure that the XServer is already running on the client machine.
  • XServer is not required when you are performing silent installation of the Application Server.

Gateway Server

Operating system

VersionRequired libraries

Red Hat Enterprise Linux

6.7 to 6.9ksh, glibc.x86_64, open-sans-fonts.noarch
7.3 to 7.5ksh, glibc.x86_64, liberation-sans-fonts

SUSE Linux Enterprise Server

11 SP3 to 11 SP4ksh, glibc.x86_64
Microsoft Windows Servers20121 
2012 R2 
2016 
Microsoft Windows10 
CentOS6.7 to 6.9ksh, glibc.x86_64
7.3 to 7.5ksh, glibc.x86_64
Oracle Linux6.7 to 6.9ksh, glibc.x86_64
7.3 to 7.5ksh, glibc.x86_64

1 - Server Core installations for Microsoft Windows Server are not supported.

Capacity Agent

Operating System support for Agent-based data collection

The following table lists the Operating Systems on which you can currently install and use Agent:

Note

  • For data collection from a Solaris 11 computer configured as a zone, the Agent must be installed on the global zone. All non-global zone data is accessible from the global zone.
  • For data collection from a 7.1, or 7.2 computer configured as a WPAR, the Agent must be installed on the global WPAR. All non-global WPAR data is accessible from the global WPAR.

  • For Z series you can only install 64-bit Agent. Compatible 64-bit for libgcc_s.so.1 and libstdc++.so.5 libraries are required to be installed for Z series.

Operating system

Supported version

Architecture and notes

AIX7.1

64-bit hardware, 64-bit kernel, POWER8, and POWER9

7.2

64-bit hardware, 64-bit kernel, POWER8, and POWER9

CentOS

6.7 to 6.9
  • x86
  • x86_64 
7.3 to 7.5

x86_64

Citrix Xen

6.5

x86_64

HP-UX



11i (B11.31)

64-bit, PA-RISC

11iv3 (B11.31)

Itanium
HP-IVM3.5*

HP Integrity Virtual Machines Manager

Red Hat Enterprise Linux

6.7 to 6.9
  • x86
  • x86_64
  • ppc64 (Big Endian)
  • zSeries (s390x)
7.3 to 7.5
  • x86-64
  • ppc64le (Little Endian)
  • ppc64 (Big Endian - POWER8, POWER9)
  • zSeries (s390x)

Oracle Linux

6.7 to 6.9
  • x86
  • x86_64 (including UEK)
7.3 to 7.5

x86_64 (including UEK)

Oracle Solaris

11.0 to 11.3

64-bit SPARC, x86_64

Note: For Oracle Solaris Sparc servers, the installation of Capacity Agents on non-global zones is not supported.

SUSE Linux Enterprise Server

11 SP3 to 11 SP4
  • x86
  • x86_64
  • POWER8, zSeries are supported (SP04)

Note: SUSE Linux Enterprise Server support includes support for all point releases within the series (for example: Open Source Xen covers support for 11.x).

12 SP2 to 12 SP3

x86_64

Microsoft Windows for Servers

2012

(including core server)

x86_64

 

2012 R2

(including core server)

x86_64

2016

(including core server)

x86_64
Microsoft Windows10 x64
Microsoft Hyper-V Server2012

x86_64

2012 R2x86_64
2016x86_64
Ubuntu

16.04 LTSEM64T (x86_64)
18.04 LTSEM64T (x86_64)
Oracle VM Server3.3 and 3.4x86_64
RHEV4.0 and 4.1x86_64

Patch requirements for Capacity Agent

The following table lists the required operating system patches.

Patch for ↓Description ↓
Solaris →


Requirement for ↓

Description ↓

Package: libpool.so.1

For Solaris 11:

  • SUNWpool
  • SUNWpoold
  • SUNWpoolr

To verify that these packages are installed, run the following command:

> pkginfo | grep SUNWpool


Supported databases and operating systems for TLS enabled communication

Requirements for TrueSight Capacity Optimization databases that need to communicate in TLS 1.2 mode

Database

Version

Oracle
  • Oracle database version:
    • For Linux: 11.2.0.4.2 Patch 19207156  
      and later
    • For Windows: 11.2.0.4.10 Patch 19651773
  • Oracle Client version is 12c or later

Also, see Oracle database documentation .

PostgreSQL

PostgreSQL 9.4 and later

Microsoft SQL Server1

2012 R2

Also, see TLS 1.2 support for Microsoft SQL Server‎ .

1 - Only supported as external database.


Operating system requirements for TrueSight Capacity Optimization components that need to communicate in TLS 1.2 mode

Operating system

Version

Supported architecture

Red Hat Enterprise Linux

6.7 to 6.9

x86_64

7.3 to 7.5

x86_64

Oracle Linux

6.7 to 6.9

x86_64

7.3 to 7.5

x86_64

CentOS

6.7 to 6.9

x86_64

7.3 to 7.4

x86_64

SUSE Linux Enterprise Server

12 SP2 to 12 SP3x86_64

Supported Oracle clients

Computers or VMs that host the TrueSight Capacity Optimization Application Server or ETL Engine server components must be running a supported Oracle client with the following packages, components, and configurations:

Oracle Client install options1

Oracle Client configurations

  • Oracle Net
  • Oracle Database Utilities
  • Oracle JDBC/THIN Interfaces
  • SQL*Plus
  • SQLLDR
  • Oracle Call Interfaces

1 These options are available only while performing a Custom installation of the Oracle Client.

  • Oracle Client 12.1.x, 64-bit

  • Oracle Client 18.x, 64-bit

Note

  • TrueSight Capacity Optimization does not support the Oracle Instant Client.
  • You must use Oracle client version 12c R1 or later with CentOS 7.x, Red Hat Enterprise Linux 7.x, and Oracle Enterprise Linux 7.x because Oracle 11g R2 is not supported on these operating systems.
Was this page helpful? Yes No Submitting... Thank you

Comments

  1. James Castronovo

    This page was easier to find on Google than it was on your KB search engine. Shouldn't that embarrass you?

    Apr 26, 2019 04:34