OS requirements

This topic describes the OS requirements for the Manager and Agent software for BMC Database Automation (BDA).

Important

To get complete compatibility information for BDA, use the BMC Solution and Product Availability and Compatibility Utility on the Product Availability and Compatibility page.

OS requirements for the Manager

The Manager software requires a server running one of the following versions of Red Hat Enterprise Linux:

  • Red Hat Enterprise Linux 7 (64-bit)
  • Red Hat Enterprise Linux 6 (64-bit)
  • Red Hat Enterprise Linux 5 (64-bit)

The Manager software requires the following Red Hat Package Manager (RPM) packages to be installed on the OS:

  • lsb_release
  • mod_ssl
  • httpd (version 2.2.xx or 2.4.xx)
  • postgresql

    Note

    You must use a version supported by the Red Hat Enterprise Linux version you are running. For example, Red Hat Enterprise Linux version 5.9 supports PostgreSQL 8.1, version 6.6 supports PostgreSQL 8.4, and version 7 supports PostgreSQL 9.2.

  • postgresql-libs
  • postgresql-server
  • glibc_i686
  • gzip
  • openssl097a or later
  • compat-libstdc++ (32-bit version required on both 32-bit and 64-bit versions of Red Hat Enterprise Linux)
  • libssh2-1.4.3-8.el5.remi.1.x86_64 (Required only if you are installing version 8.9.03 on RHEL 5)
  • openldap-2.3.43-28.el5_10.x86_64 (Required only if you are installing version 8.9.03 on RHEL 5)
  • libcurl-7.29.0-19.el5.remi.x86_64 (Required only if you are installing version 8.9.03 on RHEL 5)

Notes

  • SELinux and Firewall must be disabled.
  • If you are running a 64-bit OS, the following additional packages are required:
    • libaio.i686
    • libstdc++.i686

The Manager software also requires the use of a product-specific php RPM package. If the target server already has a php RPM package installed, the existing php RPM package must be removed from the operating system before the Manager software can be installed.

Note

The following libraries are mandatory for PHP 7.2.10:

  • OpenSSL 1.0.1 or later
  • autoconf 2.64 or later

The servers running the Manager software must have the Apache mod_ssl package installed to enable access to the GUI by using the https protocol.

Requirements for BMC Atrium Orchestrator integration

BDA uses the curl binary to send requests to BMC Atrium Orchestrator (BAO). To ensure compatibility with the SSL version installed in BAO, you must update curl on the BDA Manager to version 7.49 or later.

Requirements for supporting reports

If you plan to use the BDA reports function or BMC Decision Support for Database Automation to create reports for your environment, you must establish a data warehouse database to store the data used to create the reports. To support the connection between BDA and the data warehouse database, you must install the Oracle Instant Client on the Manager.

Beginning with version 8.6, BDA supports only the Oracle Instant Client version 11.2.0.4 to enable communication with Oracle instances.

Note

If you are upgrading to version 8.9 and later and are running prior versions of BDA where the 10g instant client is installed, you must install the 11g instant client (11.2.0.4) before upgrading. Failing to do so will result in an error during the upgrade because of the installation of a deprecated version of the client. For more information, see Installing the Oracle Instant Client.

Additional requirements for Multi-Manager configuration

If you are planning on using a Multi-Manager configuration, you must ensure the following additional requirements are met:

  • RPM packages gcc and mod_ssl must be installed.
  • The rsync utility must be installed.
  • Multiple operating systems are not supported.
  • All members of the mesh must have the same OS.
  • For megamesh to work correctly, the /home/clarity directory must exist and be owned by the clarity user.

Additional requirements for integration with BMC Cloud Lifecycle Management

If you are planning on integrating BDA with BMC Cloud Lifecycle Management, you must ensure the following additional requirements are met:

  • The following RPMs are required for PaaS support in BDA:
    • clarity-clm-content
    • clarity-clm-components
    • clarity-jre

    The install scripts provided with BDA include these RPMs as additional options to the installation but are not installed by default. They should be installed at the end of the install.sh script by typing the following:

    --clm

    These RPMs are required only when performing PaaS provisioning with BMC Cloud Lifecyle Management. If you are performing a typical installation of BDA that does not require integration with BMC Cloud Lifecycle Management, these RPMs are not installed by default.

  • Your BDA manager must be running Red Hat Enterprise Linux version 5.5 or later. If you are running a version earlier than 5.5, BMC Cloud Lifecycle Management-related components will not install.

OS requirements for the Agent

The Agent software supports the following operating systems:

  • Linux
    • Red Hat Enterprise Linux release 7 (Oracle 12c only)
    • Red Hat Enterprise Linux release 6 (64-bit)
    • Red Hat Enterprise Linux release 5 (x86 and x86_64)
    • (Supported till version 8.9.01) Red Hat Enterprise Linux release 4 (x86 and x86_64)
    • Oracle Linux release 7 (Oracle 12c only)
    • Oracle Linux release 6 (64-bit)
    • (Supported till version 8.9.01) Oracle Linux release 5 (x86 and x86_64)
    • SuSE Linux Enterprise Server (SLES) 11
    • (Supported till version 8.9.01) SuSE Linux Enterprise Server (SLES) 10
  • UNIX
    • HP-UX
      • Version 11.23 on an Intel Itanium processor and on PA-RISC
      • Version 11.31 on an Intel Itanium processor and on PA-RISC
      • Version B.11.11 on PA-RISC
    • Oracle Solaris 11 (SPARC only)
    • Solaris 10 (SPARC only)
    • (Supported till version 8.9.01) Solaris 9 (SPARC only)
    • IBM AIX 7.1
    • (Supported till version 8.9.01) AIX 6.1
  • Microsoft Windows
    • NEW IN 8.9.03Windows Server 2016 (x86_64, Datacenter Edition)
    • Windows Server 2012 (x86_64)
    • Windows Server 2008 R2 (x86_64)

The servers that run the Agent software must have the gunzip utility installed to allow updating of Agents. The gunzip utility should be installed in the following OS locations:

  • (AIX) /usr/bin/gunzip
  • (Hewlett-Packard UNIX (HP-UX)) /usr/contrib/bin/gunzip
  • (Oracle Solaris) /usr/bin/gunzip

The servers that run the Agent software must have the netstat utility. The netstat utility should be installed in the following OS locations:

  • (AIX/usr/bin/netstat
  • (Hewlett-Packard UNIX (HP-UX)/usr/bin/netstat
  • (Oracle Solaris/usr/bin/netstat
  • (Red Hat Enterprise Linux 7) /usr/bin/netstat

OS requirements for the Command Line Tools 

To run the Command Line Tools on 64-bit Linux, the following packages are required: 

  • glibc_i686
  • libstdc++.i686

Where to go next

Install the Manager software in a Standalone configuration

Was this page helpful? Yes No Submitting... Thank you

Comments