Software requirements

The following sections provide a quick overview of the software requirements for the different components of BMC Client Management.

Master, relays, and clients

BMC Client Management uses OpenJDK which is only supported on 64 bit platforms. BCM Java console cannot be launched on 32 bit platforms because they are no longer supported.


Operating System7

Master Server1,2,3,5,6,8,9,10

Relays1,2,3,4,5,6,8,9,10

Clients1,2,3,4,5,6,8,9,10
Windows


Windows Server 2008 SP2 (64 bit)

(error)

(tick)

(tick)

Windows Server 2008 SP2 (32 bit)

(error)

(tick)

(tick)

Windows Server 2008 R2 SP1

(tick)

(tick)

(tick)

Windows Server 2012

(tick)

(tick)

(tick)

Windows Server 2012 R2

(tick)

(tick)

(tick)

Windows Server 2016

(tick)

(tick)

(tick)

Windows Server 2019

(tick)(tick)(tick)

Windows 7 (64 bit)

(warning)

(warning)

(tick)

Windows 7 (32 bit)

(error)

(warning)

(tick)
Windows 7 Embedded (64 bit)(warning)(warning)(tick)
Windows 7 Embedded (32 bit)(error)(error)(tick)

Windows 8 (64 bit)

(warning)

(warning)

(tick)

Windows 8 (32 bit)

(error)

(warning)

(tick)

Windows 8.1 (64 bit)

(warning)

(warning)

(tick)

Windows 8.1 (32 bit)

(error)

(warning)

(tick)
Windows 8.1 Embedded (64 bit)(warning)(warning)(tick)
Windows 8.1 Embedded (32 bit)(error)(error)(tick)

Windows 10 (64 bit) (all versions)

(warning)

(warning)

(tick)

Windows 10 (32 bit) (all versions)

(error)

(warning)

(tick)
Linux


Linux Red Hat EL 6

(tick)

(tick)

(tick)

Linux Red Hat EL 7

(tick)

(tick)

(tick)

Linux Red Hat EL 8

(tick)

(tick)

(tick)

Linux CentOS 6

(tick)

(tick)

(tick)

Linux CentOS 7

(tick)

(tick)

(tick)
Linux CentOS 8(tick)(tick)(tick)

SUSE Linux Enterprise Server 11

(error)

(error)

(error)

SUSE Linux Enterprise Server 12

(tick)

(tick)

(tick)

SUSE Linux Enterprise Server 15

(tick)

(tick)

(tick)
Open SUSE 13.2(tick)(tick)(tick)

Linux Debian 8.0

(tick)

(tick)

(tick)
Linux Debian 9.0(tick)(tick)(tick)
Linux Debian 10.0(tick)(tick)(tick)
Linux Ubuntu LTS 16.04(tick)(tick)(tick)
Linux Ubuntu LTS 18.04(tick)(tick)(tick)
Linux Ubuntu LTS 20.04 (tick)(tick)(tick)
Mac


Mac OS X v10.10 (Yosemite)(error)(error)(error)
Mac OS X v10.11 (El Capitan)(error)(error)(error)
Mac OS X v10.12 (Sierra)(error)(tick)(tick)
Mac OS X v10.13 (High Sierra)(error)(tick)(tick)
Mac OS 10.14 (Mojave)(error)(tick)(tick)
Mac OS 10.15 (Catalina)(error)(tick)(tick)

Legend:

(tick): Fully supported.

(warning): Supported for evaluation and proof of concept only, not recommended for production environment.

(error): Not supported.

  1. Minimum requirements do not include the total requirements for the server operating system or any other application (that is, MS SQL, MS IIS, antivirus, and so on) installed on the same server.
  2. If several Client Management components (that is, Client Management Master Server, database, or web server application) are installed together on a common server, the minimum requirements for each server component must be combined, and note 1 also applies.
  3. Actual requirements and product functionality might vary based on your system configuration and operating system.
  4. Recommendation: at least 512 Kbps connectivity from audited computer to Client Management relay.
  5. Itanium 64-bit processors are not supported.
  6. Windows XP is not supported.

    Note

    BMC Client Management version 12.6 or later does not support Windows XP, but it is possible to install agents on devices running Windows XP. However, there are known issues when BMC Client Management version 12.6 or later is installed on devices running Windows XP.

    On Windows XP x64 SP2 the following issues are known:

    • Patch Inventory is not available
    • Security Products Inventory is not available
  7. Hardware used must support x86_64 architecture (Intel®-based hardware).
  8. The fontconfig 2.13 package must be installed on CentOS for graphs to be generated in reports.
  9. Windows Server 2008 SP2 is supported only without OpenJDK. It is not not supported with OpenJDK.
  10. KB2999226 is not available on Windows XP and 2003. Consequently, BMC Client Management cannot not be installed or upgraded on these operating system. To install or upgrade BMC Client Management, Microsoft Universal C Runtime is required. This component is included in the last released version of Redistributable Visual C++.

BMC Client Management master database server

Platform

Supported versions

Microsoft SQL Server

(Express, Standard and Enterprise editions (Windows masters only)

  • Microsoft SQL Server 2012 (64 bit)
  • Microsoft SQL Server 2012 (32 bit)
  • Microsoft SQL Server 2014 (64 bit)
  • Microsoft SQL Server 2014 (32 bit)
  • Microsoft SQL Server 2016 (64 bit)
  • Microsoft SQL Server 2017
  • Microsoft SQL Server 2019

Oracle RDBMS

  • Oracle 11g: 11.2.0.2 (with 10.2.0.4/5 or 11.2.0.2 client), 11.2.0.3
  • Oracle 12c: 12.1.0.2.0, 12.2.0.1.0

  • Oracle 18c
  • Oracle 19c

PostgreSQL (Linux masters only)

  • PostgreSQL 9.5 or 6 and above
  • PostgreSQL 10.0
  • PostgreSQL 11
  • PostgreSQL 12

For more information, see Database tuning.

BMC recommends you to set the compatibility mode of the database hosted on SQL Server 2016 or SQL Server 2017 to SQL Server 2014 to avoid performance issues.

Supported directory servers

Component

Supported Platforms

Microsoft Active Directory

Microsoft Active Directory Services (ADS) 2008 R2, 2012, 2012 R2, and 2016

LDAP

Supported iOS versions for MDM

VersionSupported
iOS 10(tick)
iOS 11, 11.3, 11.4.1(tick)
iOS 12(tick)
iOS 13(tick)

Supported browsers

The BMC Client Management user interface, specifically, the MyApps application kiosk, requires one of the following browsers:

Browser

Notes

Google Chrome current version

Requires the LocalLink Add-on to be installed if intranet shares are to be advertised in MyApps.

Microsoft Internet Explorer 11

Not recommended due to security compromises and performance issues.

Microsoft Edge current version

Microsoft Edge and Microsoft Edge based on chromium both are supported.

Mozilla Firefox current version

Requires the LocalLink Add-on to be installed if intranet shares are to be advertised in MyApps.

Apple Safari (versions 11 and later)

Does not support direct links to intranet shares in MyApps.

Supported Java versions

BMC Client Management version 20.08 is delivered with OpenJDK 14.

Oracle recently announced a major change to their licensing policy and release cadence for Java SE (Standard Edition including both JDK and JRE). BMC Client Management earlier included Oracle Java (JRE) for some server processes and the Administration Console. To minimize impact of the new Oracle licensing change for users, BMC Client Management now provides support for OpenJDK through the web start installer.

BMC Client Management uses OpenJDK which is only supported on 64 bit platforms. BCM Java console cannot be launched on 32 bit platforms because they are no longer supported.

Supported email servers and platforms

Component

Supported Platforms

Email Servers with support for SMTP

  • BMC Client Management requires SMTP for sending email notifications
  • Secure SMTP (SSL)
  • Authenticated SMTP

Virus Detections

To avoid any false positive virus detections, you must set antivirus exclusions for the following objects:

  • The entire BMC Client Management agent folder
  • BMC Client Management agent files and file types

 This applies to all devices on which a BMC Client Management agent is installed, that is, master, relays, and clients.

Supported bare metal hypervisors (virtual infrastructure element)

Inventory Manager can discover bare metal hypervisors and detect their configuration and attached virtual machine, and it allows for management of those virtual machines. This functionality is supported on:

Component

Supported Platforms

VMWare

ESXi 6.x

Microsoft

Hyper-V 2012 R2, Hyper-V 2016, Hyper-V Server 2019

  1. The VMWare licensing policy limits the free version of VMware ESXi to read-only access by the VMWare vSphere SDK. To enable full functionality (that is, active management such as start/stop Virtual Machines) on a VMware ESXi host, the host must be licensed with vSphere Essentials.
Was this page helpful? Yes No Submitting... Thank you

Comments