Software requirements

This topic contains the following software requirements:

Master, relays, and clients

BMC Client Management 12.8 patch 2 and later uses OpenJDK which is only supported on 64 bit platforms. BCM Java console cannot be launched on 32 bit platforms because they are no longer supported.


Operating Systems7Master server 1,2,3,5,6,8,9,10Relays1,2,3,4,5,6,8,9,10Clients 1,2,3,4,5,6,8,9,10
Windows
Windows Server 2016(tick)(tick)(tick)
Windows Server 2008 SP2 (32 bit)(tick)

(tick)

(tick)

Windows Server 2008 SP2 (64 bit)(tick)

(tick)

(tick)

Windows Server 2008 R2 SP1(tick)(tick)(tick)
Windows Server 2012(tick)

(tick)

(tick)

Windows Server 2012 R2(tick)(tick)(tick)
Windows Server 2003 SP2 (32/64 bit)(error)(error)(error)
Windows Server 2003 R2 (32/64 bit)(error)(error)(error)
Windows XP SP2 (64 bit)(error)(error)(error)
Windows XP SP3 (32 bit)(error)(error)(error)
Windows XP Embedded with SP3 (32/64 bit)(error)(error)(error)
Windows Vista SP2 (32/64 bit)(error)(error)(error)
Windows 7 (32/64 bit)(warning)(warning)(tick)
Windows 7 Embedded (32/64 bit)(warning)(warning)(tick)
Windows 8 (32 bit)(warning)(warning)(tick)
Windows 8 (64 bit)(warning)(warning)(tick)
Windows 8.1 (32/64 bit)(warning)(warning)(tick)
Windows 8.1 Embedded (32 bit)(warning)(warning)(tick)
Windows 8.1 Embedded (64 bit)(warning)(warning)(tick)
Windows 10 (32/64 bit) (all versions)(warning)(warning)(tick)
Linux
Red Hat Enterprise 4.8 and 5(error)(error)(error)
Red Hat Enterprise 6 and 7(tick)(tick)(tick)
Suse 10(error) (error) (error) 
Suse 11(tick)(tick) (tick)
Suse 12(tick) (tick)(tick)
CentOS 4.8 and 5(error) (error) (error) 
CentOS 6 (tick)(tick)(tick)
CentOS 7(tick)(tick)(tick)
Debian 7

(error)

(error)

(error)

Debian 8 and 9(tick)(tick)(tick)
Ubuntu LTS 12.04 and 14.04(error)(error)(error)
Ubuntu LTS 16.04(tick)(tick)(tick)
Mac
Mac OS X v10.5 (Leopard)(error)(error)(error)
Mac OS X v10.6 (Snow Leopard)(error)(error)(error)
Mac OS X v10.7 (Lion)(error)(error)(error)
Intel Based Mac OS v10.8 (Mountain Lion)(error)(error)(error)
Intel Based Mac OS v10.9 (Mavericks)(error)(error)(error)
Intel Based Mac OS v10.10 (Yosemite)(error)(tick)(tick)
Intel Based Mac OS v10.11 (El Capitan)(error)(tick)(tick)
Intel Based Mac OS v10.12 (Sierra)(error)(tick)(tick)
Intel Based Mac OS v10.13 (High Sierra)(error)(tick)(tick)
Intel Based Mac OS v10.14 (Mojave)(error)(tick)(tick)

Legend:

(tick): Fully supported.

(warning): Supported for evaluation and proof of concept only, not recommended for production environment.

(error): Not supported.

  1. Minimum requirements do not include the total requirements for the server operating system or any other application (that is, MS SQL, MS IIS, antivirus, and so on) installed on the same server.
  2. If several Client Management components (that is, Client Management Master Server, database, or web server application) are installed together on a common server, the minimum requirements for each server component must be combined, and note 1 also applies.
  3. Actual requirements and product functionality might vary based on your system configuration and operating system.
  4. Recommendation: at least 512 Kbps connectivity from audited computer to Client Management relay.
  5. Itanium 64-bit processors are not supported.
  6. Windows XP is not supported.

  7. Hardware used must support x86_64 architecture (Intel®-based hardware).
  8. The fontconfig 2.13 package must be installed on CentOS for graphs to be generated in reports.

  9. Windows Server 2008 SP2 is supported only without OpenJDK. It is not not supported with OpenJDK.

  10. KB2999226 is not available on Windows XP and 2003. Consequently, BMC Client Management cannot not be installed or upgraded on these operating system. To install or upgrade BMC Client Management, Microsoft Universal C Runtime is required. This component is included in the last released version of Redistributable Visual C++.

BMC Client Management master database server

Platform

Supported versions

Microsoft SQL Server

(Express, Standard and Enterprise editions (Windows masters only)

  • Microsoft SQL Server 2008 R2 (64 bit)
  • Microsoft SQL Server 2012 (64 bit)
  • Microsoft SQL Server 2014 (64 bit)
  • Microsoft SQL Server 2016 (64 bit)
  • Microsoft SQL Server 2017 (64 bit)

Oracle RDBMS

  • Oracle 11g: 11.2.0.2 (with 10.2.0.4/5 or 11.2.0.2 client), 11.2.0.3
  • Oracle 12c: 12.1.0.2.012.2.0.1.0

PostgreSQL (Linux masters only)

  • PostgreSQL 8.4 and above
  • PostgreSQL 9.5
  • PostgreSQL 10.0

For more information, see Database best practices.

BMC recommends you to set the compatibility mode of the database hosted on SQL Server 2016 or SQL Server 2017 to SQL Server 2014 to avoid performance issues.

Supported directory servers

Component

Supported Platforms

Microsoft Active Directory

Microsoft Active Directory Services (ADS) 2008 R2, 2012, 2012 R2, and 2016

Lotus Domino

Lotus Domino 9.0

Novell eDirectory

Novell eDirectory 8.8

LDAP

Supported browsers

The BMC Client Management user interface, specifically, the MyApps application kiosk, requires one of the following browsers:

Browser

Notes

Google Chrome (version 43 and later)

Requires the LocalLink Add-on to be installed if intranet shares are to be advertised in MyApps.

Microsoft Internet Explorer 11

Microsoft Edge (version 20 and later)

Mozilla Firefox (version 38 and later)

Requires the LocalLink Add-on to be installed if intranet shares are to be advertised in MyApps.

Apple Safari (versions 8 and later)

Does not support direct links to intranet shares in MyApps.

Supported email servers and platforms

Component

Supported Platforms

Email Servers with support for SMTP

  • BMC Client Management requires SMTP for sending email notifications
  • Secure SMTP (SSL)
  • Authenticated SMTP

Virus Detections

To avoid any false positive virus detections, you must set antivirus exclusions for the following objects:

  • The entire BMC Client Management agent folder
  • BMC Client Management agent files and file types

This applies to all devices on which a BMC Client Management agent is installed, that is, master, relays, and clients.

Was this page helpful? Yes No Submitting... Thank you

Comments

  1. Mike Hess

    It would be helpful to break down Windows 10 versions and confirm compatibility. We tend to only implement every other Windows 10 version, and I always get asked if our current BMC Client Management Agent is compatible with THIS version of Windows 10.

    For instance, the current version we are looking to implement is the Fall release, Windows 10 1909. Our IT governance wants to know if 1909 is supported by BMC before we bother spending resources setting up a pilot project.

    The same will happen again in January when we begin testing BCM 12.9. Is it supported? We'd like to know before beginning work. My email is mike.hess@anthem.com if you have an answer for this question.

    Dec 16, 2019 02:26
    1. Chris Mclaughlin

      The above table states that "All Versions" of Windows 10 are supported for clients, which would imply that new/future versions are included in that. Hope that helps.

      Feb 19, 2020 01:48